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Chapter 18   
Creating Form Letter Reports  

Introduction  
This chapter explains how to create R&R reports that merge data from your 
tables into text stored in text files or table memo fields. R&R’s merge 
feature is useful for applications such as “mail merge” form letters. This 
information is presented in the following sections: 

q Introduction to Merging 
q Preparing Text for Merging  
q Attaching Files for Merging   
q Creating Merge Report Layouts 
q Features Affecting Merge Reports 

Introduction to Merging 
A merge report is like any other R&R report:  you create it by selecting a 
master table that will provide data such as names and addresses, by defining 
database relations as necessary to make information from other tables 
available, and by creating a report layout. 

The unique feature of these reports is that in addition to having database 
fields, they also include memo fields drawn from either text files or table 
memo files. These memo fields can be straight text or, more commonly, they 
can be text combined with data drawn from your tables. 

The text used in a merge report can come from either or both of the 
following sources: 

q One or more memos stored in an unformatted text file; 
q One or more memo fields stored in tables. 

In order to provide text for an R&R report, the text stored in either type of 
file must follow the conventions explained in this chapter. The file must also 
be associated with the report using either Insert ⇒ Text File (for text memo 
files) or Database ⇒ Relations (for memo fields in tables other than the 
master table).  
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After a text file or memo-field table has been associated with a report, the 
text it contains becomes one or more memo fields available for use in the 
report. 

The following sections explain how to prepare text for merging, associate 
text files and memo-field tables with your report, and insert the resulting 
memo fields on your report layout. 

Preparing Text for Merging  

Text included in a report, for example the text that provides the body of a 
form letter, can be provided either by a single, unformatted text file or by 
one or more table memo fields. Both methods are explained in the following 
sections.  

Text Files 
A text memo file can contain one or more memos. If your file contains only 
a single memo to be included in your report, you need not observe any 
special conventions in entering it. If your file contains more than one memo, 
you must follow the conventions listed below in order for R&R to identify 
each memo: 

q Identify each separate memo in the file by a name up to ten 
characters long. Precede the name with a period and enter it on a 
separate line before the text.  

q Use the left brace, {, to mark the beginning of each memo and a 
right brace, }, to mark the end. The left brace must be the first 
character on the line that follows the memo field name. 

For example, the first few lines of the FIRST memo might look like this: 

 .first 
{This is the text that will be used as the first memo field of an 
R&R-generated form letter. The text can be as long as you like.} 

You can have any number of separate memos of any length in a text file. Be 
sure to give each memo a unique name. 

Table Memo Files 
Text included in a report can also be provided by one or more table memo 
fields. The conventions you observe in entering text in these fields depend 
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on the kind of memo editor you use: that provided by your database 
software or another memo editor. 

Including Field Data in Text 
You can merge data from your tables into your memo text by including field 
names. You can also include the names of any non-memo calculated or total 
field created in R&R.  

For example, the text for a form letter based on a customer table can 
include a reference to each customer’s state of residence in the body of the 
letter, as long as the composite record contains a state field. A form letter 
based on orders, items, and prices tables can include a reference to the total 
amount of each customer’s orders, as long as the amount is a field in your 
database or an R&R calculated or total field. 

To include a field name in text, simply type the field name in the place where 
you want the data to appear. Enclose the field name within backslashes 
(e.g., \STATE\) so that R&R will be able to tell the field names from the 
text. If you have more than one field with the same name in the tables used 
in your report, precede the name of each database field with the table alias 
(for example, \CUSTOMER–> 
STATE\). 

For example, to include the city and state name from a customer table in 
text that will be used in a form letter report, you might create a memo like 
the one illustrated in Figure 18.1 (the embedded field references are shown 
in bold for clarity). 

In July, Eastern Computer Supply is offering a series of 
training seminars for all corporate customers in the 
\CITY\, \STATE\ area. The seminars will be held at the 
Hynes Convention Center in Boston on July 1-5. Each 
session will provide an introduction to one of our PC 
software products. For more information about the 
seminars, please fill out and return the enclosed 
information request form.  

Figure 18.1  Sample Text with Field Names 

When you include this text in your report, the name of each customer’s city 
will replace \CITY\ and the state name will replace \STATE\. By creating a 
query that selects only those customers who live in or near Boston (STATE 
in the list ("MA", "CT", "RI", "VT", "NH", "ME")), you can send 
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personalized form letters to those customers who might be able to attend. 
Figure 18.2 shows the type of letter that will result. 

   Eastern Computer Supply, Inc. 
 
    04/29/95 
 
William Hickock 
18 Cambridge Avenue 
Waltham, MA  01254 
 
Dear William, 
 
In July, Eastern Computer Supply is offering a series of training seminars for all corporate 
customers in the Waltham, MA area. The seminars will be held at the Hynes Convention 
Center in Boston on July 1-5. Each session will provide an introduction to one of our PC 
software products. For more information about the seminars, please fill out and return the 
enclosed information request form.  
 
    Sincerely, 
 
    Joseph Wilson 
    Training Coordinator 
 
 421 Park Avenue   Worcester, MA  01615   508-345-6686 

Figure 18.2  Sample Merge Report 

Formatting Text:  Line Endings 
Unless you indicate where line endings should occur, R&R will word-wrap 
your text within the width of the memo field, determining its own line 
endings. To preserve line endings, follow these rules:  

q If you are using an Xbase memo editor (for example, the dBASE 
III or IV editor) to create/edit a table memo field, indicate where 
you want line endings to occur in your memo text by placing a 
carriage return at the end of each line. R&R maintains these line 
endings when it formats the memo field. 

q If you are using any other kind of word processor or editor to 
create/edit text files or table memo fields, precede each carriage 
return with a line ending code, <R> or <r>. The initial carriage 
return and any that immediately follow it will cause R&R to begin a 
new line.  
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For example, the memo field excerpt illustrated in Figure 18.3 produces the 
form letter excerpt illustrated in Figure 18.4. Notice that the <R> code is 
not required when a carriage return is immediately followed by another 
carriage return to indicate a blank line. 

You can also indicate where you want line endings followed by blank lines 
by including multiple carriage returns. For example, in Figure 18.3, the 
series of two carriage returns following the first sentence results in a line 
ending and a blank line. (Note that R&R preserves blank lines in memo 
fields only when the fields have a word-wrap format. If you apply a format 
other than word-wrap, R&R changes blank lines in memo text into a single 
space in your report.) 

The enclosed software demonstrates the following features 
of our new word processor: 
 
 Support for PostScript printers<R> 
 Graphics import capability<R> 
 Automatic table of contents generation<R> 
 Automatic index generation 
 
We hope that this demonstration disk will encourage you 
to try PC Word Processor. For more information about this 
and other software available from Eastern Computer 
Supply, return the enclosed postcard to request our free 
catalog. 

Figure 18.3  Text with Line Ending Codes 

The enclosed software demonstrates the following features of our new word 
processor: 
 
 Support for PostScript printers 
 Graphics import capability 
 Automatic table of contents generation 
 Automatic index generation 
 
We hope that this demonstration disk will encourage you to try PC Word 
Processor. For more information about this and other software available from 
Eastern Computer Supply, return the enclosed postcard to request our free 
catalog. 

Figure 18.4  Text as Printed in Report 
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Formatting Text: Horizontal Spacing 
If you want R&R to preserve horizontal spacing such as paragraph 
indentations in your text, use the spacebar or the tab key depending on 
what kind of word processor or editor you use:  

q Use the spacebar if your word processor or editor represents a tab 
as the tab character (as does the dBASE IV memo editor). R&R 
treats a tab character as a single space, so that space represented in 
your memo text as one or more tab characters will not be preserved 
in your R&R report. 

q Use the tab key if your word processor or text editor represents a 
tab as a number of spaces (as does the dBASE III memo editor). 
R&R preserves spaces inserted in your memo text when these 
spaces are at the beginning of a paragraph (as in a paragraph 
indentation). Spaces that are inserted elsewhere in your text are 
preserved, unless R&R’s word-wrap places them against the left 
margin of your report. In this case, the spaces are eliminated. 

Formatting Text: Fonts and Styles 
You can include special codes that apply fonts and/or styles to portions of 
the text or to data fields included in the text. Any fonts or styles specified in 
the text itself will override fonts or styles applied to the memo field on the 
report layout.  

Note that R&R does not preserve any fonts or styles you have applied in 
your word processor.  

Fonts Codes in Text 
To apply fonts to selected text and/or data fields, follow the rules explained 
below. You can apply any font available on the currently selected Windows 
printer. Applying a font will not affect the style currently in effect. 

q To turn on a selected font, include the font code <Ftypeface> or 
<ftypeface> in your text, where typeface is the typeface name (for 
example, Times) of the font you want applied. You can enter the 
typeface name in upper, lower, or mixed case.  

q To turn off a selected font, specify another font with another font 
code or use <D> or <d> to return to the font and attribute applied 
to the memo field on the report layout. 
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For example, in the text illustrated in Figure 18.5, the <FTimes> code 
applies the Times font to the entire text. 

<FTimes>In July, Eastern Computer Supply is 
offering a series of training seminars for all 
corporate customers in the \CITY\, \STATE\ area. 
The seminars will be held at the Hynes Convention 
Center in Boston on July 1-5. Each session will 
provide an introduction to one of our PC software 
products. For more information about the seminars, 
please fill out and return the enclosed 
information request form.  

Figure 18.5  Embedded Font Codes (1) 

When this memo field is inserted in a report, the text will print in the normal 
attribute of Times font (if this font is available on the current printer). This 
font will override any font applied to the memo field on the layout. 
However, if a style is applied to the memo field on the layout, R&R will try 
to combine that style with the specified font. 

In the text illustrated in Figure 18.6, Times has been applied to the entire 
text, but Helvetica has been applied to the embedded data fields. Note that 
font codes supersede each other, and that Times must be respecified for the 
text that follows the embedded data fields. 

<FTimes>In July, Eastern Computer Supply is 
offering a series of training seminars for all 
corporate customers in the <FHelvetica>\CITY\, 
\STATE\ <FTimes>area. The seminars will be held at 
the Hynes Convention Center in Boston on July 1-5. 
Each session will provide an introduction to one 
of our PC software products. For more information 
about the seminars, please fill out and return the 
enclosed information request form.  

Figure 18.6  Embedded Font Codes (2) 

To specify point size, insert a second entry consisting of the letter “p” or 
“P” followed by a number indicating the point size. For example, to apply 
10-point Times, include these codes:  <FTimes> <P10>.  

The point size code can also be used by itself to change the point size of a 
previously specified font. For example, including <P14> in your text would 
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change the size of the font currently in effect to 14 point. Point sizes can 
have up to three integer places and one decimal place. 

Style Codes in Text 
To apply styles such as bold, italic, and underscore to words and/or fields in 
your text, follow these rules:  

q To turn on a selected style, include one of the following style codes 
in your text: 

 <B> or <b> for bold 
<I> or <i> for italic 
<U> or <u> for underscored 
<N> or <n> for normal 

 You can also combine codes other than N within angle brackets, 
for example <BI> for bold and italic. 

q To turn off a selected style, specify another style with another style 
code or use <D> to return to the font and style applied to the memo 
field on the report layout. 

You can apply underscore to words and/or fields that print in any font. You 
should apply the normal, bold, italic, and bold/italic styles only to text and/or 
fields that print in fonts for which these styles are available. 

In the text illustrated in Figure 18.7, Times has been applied to the entire 
text, and bold has been applied to the embedded data fields. Note that style 
codes supersede each other, and that the Normal style must be specified for 
the text that follows the embedded data fields. 

<FTimes>In July, Eastern Computer Supply is offering a 
series of training seminars for all corporate customers 
in the <B>\CITY\, \STATE\ <N> area. The seminars will be 
held at the Hynes Convention Center in Boston on July 1–
5. Each session will provide an introduction to one of 
our PC software products. For more information about the 
seminars, please fill out and return the enclosed 
information request form. 

Figure 18.7  Embedded Font and Style Codes 

Applying a style will not affect the font currently in effect. 

As long as no other style is applied to the memo field on the report layout, 
this memo field will print in the normal style of the Times font. However, the 
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embedded data fields will print bold style, assuming this style is available for 
Times. 

Note that you can include style codes without using font codes. In this case, 
R&R will combine the specified style with the font that is applied to the field 
on the report layout. 

Formatting Text: ASCII Characters 
Note that R&R ignores all ASCII control characters (such as tabs or form 
feeds) included in your text except carriage returns.  

Attaching Files for Merging   

After you have prepared a text file or table memo field, you are ready to 
create your form letter report. The first steps are the same as with any 
report: 

q Select a master table for the report, often the one that will provide 
names and addresses for the letters. 

q Optionally set database relations that join any other tables that will 
provide information for the report. 

The next step varies depending on the type of memo file you use. 

Using Text Memo Files 
If you are storing memos in a text memo file, you must tell R&R which file 
contains the memo(s) that will provide the text of the form letter. To select a 
memo file, do the following:   

1. Select Insert ⇒ Text File (see Figure 18.8). Either enter the name of 
the text file or choose Select File and choose from the listed files.  

2. R&R assigns an alias to the file that consists of the file name without an 
extension. You can accept the default name unless one of the tables in 
your report has the same alias. In this case you must enter an alias that 
is not the alias of any table used in the report.  
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Figure 18.8  Insert Text File Dialog Box 

3. If the text file you attached uses extended characters (for example, 
currency symbols or foreign characters), in the Character Set group box 
select the character set that the text file uses (see the section in this 
chapter entitled Specifying Character Set for an explanation of these 
choices).  

4. Select OK. The name of each memo in the text file will now appear in 
the field list under the name of the master table.  

You can select only one text memo file at a time, so all the memos you want 
to include in a letter must be in the same file. Within this file, you may have 
many named memos, one or more of which can be included in your report. 
See the section in this chapter on preparing memo files for information about 
including more than one memo in a memo file. 

When you save your report, your memo file selection will be saved just like 
your database relations. 

Specifying Character Set 
The Character Set group box on the Text File dialog contains two choices: 
Windows (ANSI) and DOS (PC). Use this setting to specify what 
character set your memo text files use for extended characters. Generally 
speaking, you should select Windows (ANSI) for text files created with a 
Windows word processor; you should select DOS (PC) for text files 
created with a DOS-based word processor.  

Using a Table 
If you are using memo fields from a table other than the master table, you 
must use this table in your report by creating a database relation that relates 
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the table containing the memo field(s) to one of the other tables used in the 
report. 

For example, you might generate a variety of form letters to send to 
customers by relating a table containing memo fields for each paragraph of 
each letter (MEMO.DBF) to a master customer table containing one record 
for each customer (CUSTOMER.DBF). If the memo table has no fields in 
common with the CUSTOMER table, you can define this database relation 
using a calculated linking field to provide a record number as follows:  

1. Create a calculated linking field whose expression results in a number 
corresponding to the number of the record in MEMO.DBF containing 
the memo(s) you want to include in the form letter. 

2. Set an exact-lookup database relation between the CUSTOMER and 
the MEMO tables, selecting the calculated field you just created as the 
linking field and Record Number as the related table Link Control. 

Note that the value for the calculated linking field can be a constant if you 
have stored all your memos as memo fields in a single record.  

Note also that you may relate more than one table to provide memo fields 
for a report. 

Memo Fields 
After you have associated a memo file with your report using either of the 
procedures explained previously, the memos in the files are available as 
fields to be used in the report. They display in the Field list as follows: 

q Memo fields provided by inserted text files display in the Field list 
as [memo name]. If your memo file has only one unnamed memo, 
that memo appears as [memo file alias].  

q Memo fields provided by related tables will display in this list as 
[table file alias]–>[memo field name]. 

Creating Merge Report Layouts  

You create the layout for a merge report just like you create the layout for 
any other report. You insert blank lines of the appropriate types on the 
layout; then you insert text and fields. For example, the layout that produced 
the letter in Figure 18.2 is illustrated in Figure 18.9 
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Figure 18.9  Sample Form Letter Layout 

Memo Field Symbol 
Note the line of m’s that represents the text of the letter. These m’s 
represent a memo field that will appear in the letter as a paragraph of text.  

Since the number of lines that memo fields contain when printed varies, each 
memo field appears on your screen as a single line of m’s. The default 
format of the memo field (indicated by the « that precedes the m’s) is left-
justified word-wrap. This format causes all the text in the memo field to 
word-wrap within the maximum report width, 254 columns (when Ruler 
Spacing is set to 10). After you insert a memo field, use Format ⇒ Field to 
set a width appropriate for your report.   

Generating Merge Reports 
To generate a merge report such as a series of form letters, simply click on 
the Print button on the Standard Toolbar or use the Print dialog. Before you 
print, you can use the Database ⇒ Sort Order and Query dialogs to sort 
the report and print only selected records, if necessary. 
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Features Affecting Merge Reports 

A number of R&R features have special relevance to merge reports. 
Although each of these features is discussed at length elsewhere in the 
manual, this section briefly explains five important features: 

q Word-wrap format and width of memo fields; 
q Field width and format of embedded data fields; 
q Functions that conditionally include memo fields; 
q Options that control printing of blank lines; 
q Page breaks. 

Word-Wrap Format of Memo Fields 
When you first insert a memo field in a report, it defaults to left-justified, 
word-wrap format. While you can change the justification of the field to 
right or full, you will probably not want to change the word-wrap format. 
(Only if the field is word-wrapped can you be sure to print all the text from 
the memo field.) As you insert the memo field on your report layout, you 
should be aware of the characteristics of this format, which are summarized 
in the following paragraphs. 

q If you place a word-wrapped memo field in a Page Header/ 
Footer or swap Header/Footer band, R&R wraps the text only until 
it encounters the end of the area, as these areas are fixed in length. 
Any data that does not fit in the area will not print. 

q If you place a word-wrapped memo field in any band other than a 
Page Header/Footer or swap Header/Footer, R&R wraps the text 
until the entire contents of the memo field have been printed, causing 
these areas to vary in length. 

For more information on word-wrapping and justification, see Chapter 5, 
“Working with Fields.” For a definition of swap Headers/Footers, see 
Chapter 11, “Sorting and Grouping Data.” 

Field Width of Memo Fields 
The width of the memo field determines the horizontal area within which 
R&R wraps the text. The maximum width of a memo field is 254 
characters. If you want to indent the memo text on the report, you can use 
the Format ⇒ Field dialog to specify memo field width in characters or 
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inches; then move the field into position on the layout. For more information 
on controlling field width, see Chapter 5, “Working with Fields.” 

For example, the layout shown in Figure 18.10 produces the report shown 
in Figure 18.11. 

 

Figure 18.10  Report Layout with Two Memo Fields  

This memo is the introductory paragraph and 
prints across the page from the left margin  
to a width of 45 characters. 
 
 This memo field is shorter and only 
 prints within a field width of 35 
 characters. 

Figure 18.11  Report Output with Two Memo Fields 

Field Width and Format of Embedded Data Fields 
Numeric, date, and logical fields embedded in a memo field appear with the 
same width and format that has been assigned to the fields in the report. To 
change the field width or format of a numeric, date, or logical field that has 
been embedded within a memo field but not inserted on the report layout, 
insert the field anywhere on the report. Use the Format ⇒ Field dialog to 
change the field width or format. Then erase the field from the report layout. 
When the field is merged with the memo field in your report, it will have the 
width and format you assigned it. 

Note that the entire contents of an embedded character field are printed, 
with leading and trailing spaces removed. 

Conditionally Including Memo Fields 
If your merge report is composed of several memo fields, you can use the 
IIF or CASE function to conditionally include memo field text. For example, 
if you want to print the PAYUP memo field only if the addressee balance is 
past due, you can create a calculated field with the following expression: 

 IIF(PASTDUE,PAYUP,"") 



 Chapter 18  Creating Form Letter Reports 

Using R&R, Windows Xbase Edition 321 

This expression means that if the value in the PASTDUE field is true, the 
PAYUP memo field will be printed. Otherwise, nothing will be printed. The 
empty quotation marks return an empty memo field without the need for you 
to have such a field in your memo file.  

Note that the quotation marks indicating the empty memo field must be the 
second return value in the expression. 

Once you have created this field, you can insert it in your form letter where 
you want the memo text to appear. Customers with a past due balance will 
receive letters including the text of PAYUP; paid up customers will receive 
letters without this text. 

The CASE function can be used in a similar way to select from a series of 
memo fields. For example, to print different memo fields depending on the 
length of time customers’ bills are overdue, you might proceed as follows. 
First, create an OVERDUE field that contains a 0 if the bill is not overdue, 
1 if it is between 30 and 60 days overdue, and a 2 if it is more than 60 days 
overdue.  

Create corresponding memos named THIRTY and SIXTY in a text file. 
Then create a calculated field with the following expression: 

 CASE(OVERDUE,2,SIXTY,1,THIRTY,"") 

This expression means that if the value in the OVERDUE field is 2, print the 
SIXTY memo field; if the value in the OVERDUE field is 1, print the 
THIRTY memo field; if the value is 0 or any other value, print no memo 
field. Note that the quotation marks indicating the empty memo field must 
not be the first result in the expression. 

Note also that you can use the Format ⇒ Band Line Properties dialog to 
assign a logical condition that will conditionally print lines in any report. See 
Chapter 4, “Working with Bands,” for more information. 

Blank Lines 
You can print blank lines in any report simply by inserting them on the 
report layout. In the Title, Record, Group Header/Footer, or Summary 
bands, R&R always places blank lines where you have inserted them 
relative to word-wrapped fields. For example, if a report layout contains 
two memo fields separated by a blank line, as shown in Figure 18.10, R&R 
prints all the text in the first field, leaves a blank line, and then prints the 
second memo field, as shown in Figure 18.11.  

You can control the printing of lines in which all fields are empty by using 
the Compress Record/Group Lines setting in the Format ⇒ Record Layout 
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dialog. Turning this setting Off forces the printing of a Record, Group 
Header, or Group Footer line in which all fields are empty. R&R initially 
sets this option to On, which suppresses printing of lines in which all fields 
are empty. If you have used an IIF or CASE expression as explained 
previously to conditionally exclude memo fields, you should retain the 
default of On. 

Page Breaks 
When printing a merge report such as a series of form letters in which you 
want to start a new page for each record or group, insert a new-page line 
as the last line before the Page Footer. For information on inserting new-
page lines, see Chapter 4, “Working with Bands.” 

 

 


