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Chapter 2   
Using R&R Menus and Dialogs   

Introduction  

This chapter describes all components of the R&R window and explains 
R&R commands and the on-line help system.  

This information is presented in the following sections: 

q Understanding the Main R&R Window 
q Using R&R Dialog Boxes 
q Selecting from R&R Menus 
q Using Command-Line Switches 

Understanding the Main R&R Window  

When you run R&R, the R&R startup dialog displays. After you have 
selected a report to edit or a starting point for creating a new report, the 
main R&R window appears. This window contains the following 
components: 

q A Title Bar; 
q A Menu Bar containing File, Edit, View, Insert, Format, Options, 

Database, Calculations, and Help selections; 
q A Standard Toolbar of buttons for running R&R commands;  
q A Formatting Toolbar of buttons and edit boxes for formatting fields 

and specifying other layout settings;   
q A blank Work Space with horizontal and vertical rulers; 
q A Status Bar.  

In addition, the window includes an edit cursor, a blinking vertical line that 
shows the insertion point for placing objects. Figure 2.1 illustrates a sample 
window. 

You can access all R&R commands from the Menu Bar; the Toolbars give 
you quick access to commonly used commands. When you position the 
cursor over each of the Toolbar buttons, a ToolTips help label appears 
explaining its purpose. 
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You can display R&R in a maximized window or re-size the window as 
necessary (follow the procedures explained in your Windows 
documentation for re-sizing the window).  
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Figure 2.1  Main R&R Window 

Using the Menu Bar 
The Menu Bar contains the “top-level” R&R commands: File, Edit, View, 
Insert, Format, Options, Database, Calculations, and Help. You can select 
a command on this menu in any of the following ways: 

q Click on it;  
q Type Alt plus the underlined letter in the command;  
q Press F10, use the cursor keys to highlight the command, and press 

Enter.  
Selecting any one of these commands displays a menu of additional 
commands that open R&R dialog boxes or perform specific actions on 
selected objects or lines. See the Selecting from R&R Menus  section in 
this chapter for a summary of each command menu.  

Using the Standard Toolbar   
For many R&R commands, you can select a button on the Standard 
Toolbar (see Figure 2.2) instead of selecting from the Menu Bar. Clicking 
on one of these buttons either executes an R&R command or opens a 
dialog box in which you can select or change various options.  
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Figure 2.2  Standard Toolbar 

You use View ⇒ Toolbars to control display of the Standard Toolbar. 
Click the check box next to “Standard” on the Toolbars dialog to turn the 
bar on (checked) or off (empty).  

Figure 2.3 identifies the Menu Bar command (and associated shortcut key if 
applicable) that corresponds to each Standard Toolbar button. 

Toolbar 
Button 

Menu Bar 
Command 

Shortcut  
Key 

 File ⇒ New Ctrl+N 

 File ⇒ Open Ctrl+O 

 File ⇒ Save Ctrl+S 

 File ⇒ Print Ctrl+P 

 File ⇒ Print Preview  

 Edit ⇒ Cut Ctrl+X 

 Edit ⇒ Copy Ctrl+C 

 Edit ⇒ Paste Ctrl+V 

 Insert ⇒ Line  

 Insert ⇒ Box  

 Insert ⇒ Picture  

 Database ⇒ Master Table  

 Database ⇒ Relations  

 Database ⇒ Sort Order  

 Database ⇒ Group Order  

 Database ⇒ Query  

 Calculations ⇒ Calculated Field  

 Calculations ⇒ Total Field  

Figure 2.3  Toolbar Buttons and Corresponding Commands 
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Using the Formatting Toolbar  
The Formatting Toolbar that optionally displays below the Standard 
Toolbar provides a quick way of formatting fields and text in your report. 
After you select one or more items on the report layout, you can specify 
font, point size, style, and alignment by using the list boxes and buttons on 
this bar.  

In some cases you may want to hide the Formatting Toolbar — for 
example, if you want to display more of the report layout without having to 
scroll. You use View ⇒ Toolbars to control display of the Formatting 
Toolbar. Click the check box next to “Formatting” to turn the bar on 
(checked) or off (empty). 

 

Figure 2.4  Formatting Toolbar 

Figure 2.5 briefly explains each item on the Formatting Toolbar.   

Toolbar Item Purpose 

Font Apply a font to one or more selected fields 
Size Select or enter a size for the current font 

Style Buttons B for Bold, I for Italic, U for Underline 
Alignment 

Buttons 
Non-word-wrapped fields:  Left, Center, Right; 
word-wrapped fields:  Left, Right, Justified 

Trim Button Turns automatic trim on or off 
Trashcan 

Button 
Deletes currently selected item(s) or restores most 
recently “trashcanned” item(s) 

Auto/Freeform 
Button 

Toggles between Automatic/Freeform line height 
(see Chapter 4, “Working with Bands”) 

Snap-To-Grid 
Button 

Turns snap-to-grid on or off 

Figure 2.5  Formatting Toolbar Items 
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Using the Bold, Italic, and Underline Buttons 
The style and underline buttons (B, I, and U) serve as toggles that turn each 
style on or off. For example, to make a selected item bold, click the Bold 
button. To remove the bold style, click the same button. The item’s 
representation on the layout changes to indicate the selected style. You can 
apply more than one style to the same item. (Bold or Italic will print only if 
available for the currently selected font.) 

Using the Alignment Buttons 
R&R assigns a default alignment to each field when it is inserted on the 
layout. A field’s default alignment depends on its data type: 

q Numeric fields are right-aligned; 
q Memo fields are word-wrapped, left-aligned; 
q All other fields are left-aligned.  

You can find out the alignment of any field by looking at its representation 
on the report layout (for character and memo fields, the first character of the 
field symbol represents the field’s alignment), by using the Format ⇒ 
Alignment command, or by selecting the field and pressing F4 to open the 
Field Properties dialog.  

To change field alignment, select the field and click one of the alignment 
buttons (Align Left, Center, Align Right, or Justify). See Chapter 5, 
“Working with Fields,” for more information about alignment and alignment 
symbols. 

Using the Other Formatting Buttons 
The remaining items on the Formatting Toolbar provide quick access to 
common formatting and editing tasks: 

♦ The Trim button controls automatic trimming of blank space 
between fields on the same line (you can also control trim by 
selecting Format ⇒ Trim).  

♦ The Trashcan button provides a quick way of clearing selected 
objects or restoring the most recently “trashcanned” item(s).  

♦ The Auto/Freeform button toggles between Auto and Freeform line 
height type for a line or group of lines (see Chapter 4, “Working 
with Bands,” for an explanation of Automatic and Freeform line 
height). 

♦ The Snap-To-Grid button turns snap-to-grid on or off.  



Introduction to R&R 

16 Using R&R, Windows Xbase Edition 

Changing Horizontal and Vertical Ruler Settings  
Calibrated horizontal and vertical rulers help you place fields and text at 
specific positions on the report layout. For example, if you type a left-
justified column heading on the layout immediately under the 1 inch position 
on the horizontal ruler, this column heading will begin printing one inch from 
the left margin of your report. 

The left, right, or center alignment point for a selected item is marked by a 
location indicator on the horizontal ruler. Vertical position is marked by a 
darkened band in the Band Area. 

The default setting for both the Horizontal and the Vertical Ruler Spacing is 
10; you can select a setting from 4 through 30. This setting controls the 
number of ruler increments per inch on each ruler. Note that the Ruler 
Spacing settings control only the spacing of the report layout rulers (since 
the fonts actually applied to fields in the report control the print spacing). 

When the grid is turned on, the ruler settings determine the horizontal and 
vertical grid spacing for Freeform lines. For Automatic lines, the horizontal 
ruler setting determines the horizontal grid spacing; the vertical grid spacing 
is determined by the height of the largest font on each line. See Chapter 4, 
“Working with Bands,” for an explanation of Automatic and Freeform line 
height. 

You can change the calibration of the rulers by double- or right-clicking on 
either ruler or by pressing F8. The dialog box illustrated in Figure 2.6 
appears. 

 
Figure 2.6  Ruler Spacing Dialog Box 

To change ruler spacing, in the “Units Per Inch” box enter or select a 
number from 4 to 30 representing the number of ruler divisions per inch. 
Then select OK. For example, if you set “Units Per Inch” for the horizontal 
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ruler to 4, the horizontal ruler scale and grid markings are arranged in ¼-
inch increments.  

Work Space  
The area below the horizontal ruler line is the Work Space in which you 
create report layouts. The Work Space is divided into two main areas: 

q The Band Area — the area to the left of the screen, which identifies 
the type and status of every band line on the layout. 

q The Layout Area — the large blank area in which you create a 
report layout, a schematic representation of your report that 
contains the fields and text that will appear on your report.  

Band Area 
The Layout Area consists of one or more bands, each with characteristics 
that define how the data in that band will be presented when the report is 
run. As Figure 2.1 on page 12 illustrates, the Band Area contains a band-
type indicator for each band in the Layout Area. Band-type indicators, 
which R&R automatically displays when you create, insert, or move lines, 
identify whether a line is part of the report’s Title, Page Header, Group 
Header, Record band, Group Footer, Summary band, or Page Footer. To 
select one or more lines, click or drag the mouse in the Band Area.  

The narrow channel at the right edge of the Band Area is the Line Status 
Area. This area provides the following information about report lines: 

q Up and down arrows in the Line Status Area indicate the top and 
bottom border of any Freeform line (for a full explanation of 
Freeform lines, see Chapter 4, “Working with Bands”).  

q A question mark indicates that a logical field or scan condition has 
been assigned to control printing of that line. (See Chapter 4, 
“Working with Bands,” for information about controlling line 
printing with logical fields; see Chapter 17, “Creating Multiple-Scan 
Reports,” for information about scan conditions.) 

Layout Area 
The Layout Area typically contains text, which will appear in the report 
exactly as typed, and data fields, which are represented on the layout either 
by field symbols such as <xxxxxx (character data) and 99999 (numeric 
data) or by field names (if the Field Names setting has been enabled on the 
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View menu). This area can also contain lines, boxes, and bitmapped graphic 
images. 

The Layout Area can be scrolled both vertically and horizontally. You can 
create report layouts up to a maximum of 256 lines; the maximum layout 
width is determined by the page layout settings. 

See Chapter 5, “Working with Fields,” for information about adding text 
and fields to a report layout. See Chapter 13, “Adding Lines, Boxes, and 
Shading,” for information about drawing lines and boxes. For an 
explanation of inserting and sizing images, see Chapter 14, “Inserting 
Bitmapped Images.” 

Using the Status Bar and Scroll Bars  
Immediately below the Work Space is the Status Bar, which displays 
information about current operations and/or the position of a selected item. 
At the bottom and right of the R&R main window are the horizontal and 
vertical scroll bars, which enable you to scroll the Work Space up and 
down, left and right. 

Status Bar 
When you are working in the Layout Area, the Status Bar identifies the 
position of the edit cursor on the layout and indicates whether the “Caps 
Lock” or “Num Lock” key on your keyboard is on. In addition, the Status 
Bar may contain descriptions of command options, prompts telling you what 
action to take, or information about the currently highlighted field.  

Scroll Bars 
Use the horizontal and vertical scroll bars to scroll the Work Space. Both 
the Band Area and the Layout Area can be scrolled vertically. However, 
only the Layout Area can be scrolled horizontally, since the information in 
the Band Area is relevant to the entire width of the report layout. For 
information about scrolling an application window, see your Windows 
documentation. 

Selecting from R&R Menus  

You execute R&R commands by selecting from menus or clicking buttons 
and then using dialog boxes to provide additional information required by 
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some commands. Operation of both the R&R menus and dialog boxes 
follows the Windows conventions explained in the following sections. 

The R&R Menu Bar is the main R&R menu, from which you select the 
command menus you want to use. For example, selecting File in the Menu 
Bar will display the File menu. 

You can open a command menu from the Menu Bar in any of the following 
ways: 

q Click on the command name. 
q Press F10 (or Alt) and type the accelerator key for the command 

(the underlined letter in the command name — for example, F for 
File or E for Edit).  

q Press F10, use the cursor keys to highlight a command name, then 
press Enter. 

After opening a menu, you select a command in any of these ways: 

q Click on the command name. 
q Type the accelerator key for the command. 
q Use the cursor keys to highlight a command; then press Enter. 

For example, after opening the File menu, you can select “New” by clicking 
on it, by typing N, or by highlighting the command and pressing Enter. 
Cancel a command selection by clicking outside the menu box or by 
pressing Esc. 

You can also execute some commands directly from the keyboard, without 
using the Menu Bar, by typing a shortcut key combination. For example, 
you can execute Format ⇒ Alignment by pressing F3.  

At some points, one or more commands on the Menu Bar or in the 
command menus will be dim, indicating those commands are not available.  
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File Menu 
Use the File menu to do the following: 

q Create, open, close, save, print, or preview a report; 
q Select a report library or create a new report library;  
q Select a different printer; 
q Enter or edit comments for the current report; 
q Export a report to a plain text, database, worksheet, text data, Rich 

Text Format (RTF), or Word merge file or to an Excel 5.0 
PivotTable or Chart; 

q Exit R&R. 

Selecting File displays a menu of choices; selecting a choice either opens a 
dialog or executes an R&R command. Figure 2.7 summarizes the actions 
these menu choices perform.  

Command Purpose 
New (Ctrl+N) Create a new report 
Open (Ctrl+O) Open or delete a report; select a library 
Close Close Report 
Save (Ctrl+S) Save a report 
Save As Save a report with a different name or in a 

different library 
Summary Info Enter comments for current report 
Page Setup Specify paper size, margins, orientation 
Printers Select a different Windows printer 
Print Preview Display the current report on the screen 
Print (Ctrl+P) Print a report on the current printer or change 

print options 
Export Output report data to a plain text, database, 

worksheet, text data, RTF, or Word merge file 
or to an Excel 5.0 PivotTable or Chart 

Exit (Alt+F4) Leave R&R and return to Windows 

Figure 2.7  File Menu Choices  
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Note that the Page Setup settings for paper size, margins, orientation, and 
interline spacing apply only to the current report and are saved with it. 

Edit Menu 
The Edit menu provides choices for modifying reports — cutting and 
pasting, copying, deleting, moving, and so on. Figure 2.8 summarizes the 
purpose of each Edit menu choice.   

Command Purpose 
Undo (Ctrl+Z) Undo last Clear 
Cut (Ctrl+X) Remove selected object(s) and save to 

memory 
Copy (Ctrl +C) Copy selected object(s) to memory  
Paste Objects (Ctrl+V) Paste objects saved to memory 
Clear Erase selected object(s) 
Paste Clipboard Image Paste graphic image from clipboard 
Move Fields (F7) Move selected field(s) or band line(s) 

using cursor keys 
Duplicate Fields (Shift F7) Copy selected field(s) for movement 

using cursor keys 

Figure 2.8  Edit Menu Choices  

View Menu  
Use the View menu to do the following: 

q Turn Standard Toolbar display on or off; 
q Turn Formatting Toolbar display on or off; 
q Turn ToolTips display on or off; 
q Turn horizontal or vertical ruler on or off; 
q Turn grid display on or off; 
q Display fields either as symbols or as field names.   

By default, the Toolbars and rulers are displayed; fields are represented by 
symbols on the layout; and the grid is shown. To change these settings, 
select View; then select the item to change.  
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Command Purpose 
Toolbars Hide or show the Standard and Formatting 

Toolbars; enable or disable ToolTips display 
Horizontal Ruler Hide or show the horizontal ruler 
Vertical Ruler Hide or show the vertical ruler 
Grid Hide or show the grid 
Field Names Display fields as symbols or as names 

Figure 2.9  View Menu Choices 

Toolbar and ToolTips Settings 
A check mark next to either “Standard” or “Formatting” on the Toolbars 
dialog means that the item is currently displayed. To turn off display of 
either, select the appropriate item.   

A check mark next to the “ToolTips” item on this dialog means that a help 
label will display when you position the cursor over one of the toolbar items. 
To turn off display of these labels, click the box to remove the check mark. 

Horizontal and Vertical Rulers 
To turn on or off the display of the horizontal or vertical ruler, select 
Horizontal Ruler or Vertical Ruler. A check mark next to either indicates 
that display is currently turned on. 

Grid 
To help you align objects on the report layout, you can enable a grid 
consisting of a series of dots. To control grid display, select View ⇒ Grid; 
a check mark appears when this setting is on. When the Snap-To-Grid 
setting is on, items that you insert or move will “snap” to the nearest grid 
mark. See the Format Menu section of this chapter for information about 
turning Snap-To-Grid on or off. 

Field Names 
Fields can be represented on the layout either by field names or by symbols 
(such as >xxxxx) that identify field type and alignment. By default, each field 
is represented by symbols. To display field names instead, turn on the View 
⇒ Field Names setting (a check mark appears next to the setting when it is 
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on). As a result, each field’s name is shown at the field’s location 
(depending on field width, the entire name may not appear). 

Insert Menu 
Using the Insert menu choices, you can insert fields from the composite 
record structure (the set of fields available to be used in a report, including 
master and related table fields and any R&R total or calculated fields); 
create and insert band lines; attach a text file to provide memo fields for the 
report; and insert lines, boxes, or images. (See Chapter 18, “Creating Form 
Letter Reports,” for information about preparing, attaching, and using a text 
memo file.) 

Figure 2.10 briefly explains the Insert menu commands. 

Command Purpose 
Field (Ins, F11) Insert field from composite record structure 
Band Line  
(Shift+F11) 

Insert line of same type above current line 

Create Band Line 
(Ctrl+F11) 

Insert one or more lines of any band type 

Text File Insert text memo file 
Line Draw horizontal or vertical line 
Box Draw box or add shading 
Picture Insert bitmapped graphic image 

Figure 2.10  Insert Menu Commands  

Format Menu  
The following Format menu choices enable you to control the format and 
alignment of fields and lines:  Alignment (F3), Font (F5), Field (F9), Trim, 
Band Line Properties, Band Line Justify, Rulers (F8), and Snap-To-Grid 
(Shift+F8). Figure 2.11 lists the commands and explains the purpose of 
each. See Chapter 5, “Working with Fields,” for detailed information about 
using these commands.  
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Command Purpose 
Alignment (F3) Set Left, Center, Right, Word Wrap alignment 
Font (F5) Specify typeface, size, and style 
Field (F9) Modify field format (width, number of integers 

and decimals, numeric format, etc.) 
Trim Turn automatic trim on or off 
Band Line 
Properties 

Control line height and logical conditions 

Band Line Justify Align all fields on selected lines 
Record Layout Specify various record formatting options 
Rulers (F8) Change horizontal and vertical ruler spacing 
Snap To Grid 
(Shift+F8) 

Turn snap-to-grid on and off 

Figure 2.11  Format Menu Choices  

The Record Layout dialog provides settings for formatting the Record and 
Summary bands of a report, including selections for multiple and “snaked” 
columns, Avery labels, and number of record copies.  

Options Menu  
The Options command provides the following choices: Preferences, Default 
Settings, and File Settings. Figure 2.12 summarizes the settings available 
with each.  

Command Purpose 
Preferences Turn scroll bars on and off; control result of 

selecting File ⇒ New; specify memo editor; 
specify display of field names, report dictionary 
descriptions, or both in field lists 

Default Settings Set paper size, margins, font, spacing, logical 
strings 

File Settings Specify default library and image directories; 
default image, text , and index file extensions; 
template library, report dictionary, and report 
dictionary index 
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Figure 2.12  Options Menu Choices   

You use the Preferences dialog box to control the display of horizontal and 
vertical scroll bars and to specify what action R&R will take when you 
select File ⇒ New. You also use this dialog to indicate which database 
memo editor was used to prepare tables that supply memo fields for your 
reports.  

In addition, if you have defined a report dictionary file for your database, 
you can use the Field Lists section of the Preferences dialog to specify the 
content of field lists in R&R.  

See Chapter 6, “Setting Defaults,” for more information about the 
Preferences dialog.  

The Default Settings dialog controls global settings for paper size, margins, 
font and point size, font color, ruler spacing, logical strings, and snap-to-
grid. These settings apply to all newly created R&R reports. The Default 
File Settings dialog enables you to set default data, library, and image 
directories; specify default file extensions for index, text memo, and image 
files; and specify a default template library, report dictionary, and report 
dictionary index. 

Database Menu  
Use the Database menu choices to specify the tables from which data will 
be drawn for an R&R report, to sort and group that data, to select a master 
index, to specify a scope for the master table, and to create a query to 
select specific records. Figure 2.13 briefly summarizes the Database menu 
choices.  

Command Purpose 
Master Table Select or change master table; apply scope; select 

master index; assign alias  
Relations Select, edit, and remove table relations 
Sort Order Select fields to control report sort order 
Group Order Select fields to group report data 
Query Specify selection conditions to filter records 

Figure 2.13  Database Menu Choices   
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Calculations Menu  
The Calculations menu choices enable you to create and edit calculated 
fields, total fields, and User-Defined Functions (UDFs), as well as to purge 
a report of any unused total and/or calculated fields.   

Command Purpose 
Calculated Field Create and edit calculated fields 
Total Field Create and edit total fields 
User Function Create and edit User-Defined functions 
Auto Total Create totals for all selected fields 
Purge Calculations Remove all unused calculated or total fields 

Figure 2.14  Calculations Menu Choices 

You use the Calculated Fields dialog box to create fields whose values are 
computed as a report is generated, rather than being retrieved from the 
database. You use the Total Fields dialog to create fields that contain 
summary information such as a subtotal or grand total figure; R&R 
calculates the value of such a field according to the total options you select. 
You can create total and calculated fields, insert them in reports, and 
manipulate them just as you do data and text fields.  

You use the User Function dialog to create UDFs to process data 
according to an expression or formula that you define. You can create 
UDFs to perform complex operations and then use those UDFs (in the 
same way you would use predefined functions) in calculated field 
expressions in any R&R report.  

The Auto Total dialog enables you to select multiple fields on the layout and 
have R&R automatically create totals for those fields and insert the totals on 
a new band line. 

Use the Purge Calculations command to remove any unused total and/or 
calculated fields from the report definition. Removing unused total and 
calculated fields can speed up report generation and reduce the amount of 
memory required. 
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Using R&R Dialog Boxes  

Like other Windows applications, R&R uses dialog boxes to request and 
display information related to a specific command.  

Many of the dialog boxes in R&R are standard Windows dialog boxes. For 
example, the R&R File ⇒ New dialog box is like the File New dialog in 
many Windows applications.  

Note that some dialogs shown in this manual (for example, dialogs for 
selecting tables or for inserting bitmapped graphics) include a Network 
button that enables connection to a network drive for file selection. These 
dialogs are Windows for Workgroups Version 3.11 common dialogs; the 
appearance of such dialogs may differ if you are running some other version 
of Windows. 

Other dialog boxes are unique to R&R, since they request information 
specific to report generation. For example, the Database ⇒ Query dialog 
box requests information that enables R&R to construct a query selecting 
specified records for a report.  

You can move around in a dialog box using either the mouse or the 
keyboard. Using a mouse, simply click on any option to make it active. 
Using the keyboard, tab from option to option or press Alt plus the 
underlined letter in the option you want to select. When an option is active, 
it is marked by a highlight or dotted rectangle. 

List and Edit Boxes  
A list box is any vertical list from which you select a setting, file, or other 
item. Many dialog boxes contain edit boxes in which you can enter text 
such as paths, file names, field names, or numeric values. In some cases, an 
edit box and list box are combined so that you can either select from the list 
or type your choice in the edit box (such boxes are often referred to as 
“combo boxes”).  

List Boxes 
Some list boxes open automatically when you select a command or item; on 
some dialog boxes, you must first click the scroll arrow next to an item to 
open a list box containing choices for that item. To select a choice from a 
list box, either click on the choice or use the cursor keys to highlight it. 
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From the keyboard, you can select a field from a field list box by typing the 
first letter of the field name until the field is highlighted on the list.  

Note that the complete field name is displayed in the Status Bar when a field 
is highlighted in the field list box. 

Edit Boxes 
To enter or modify text in an edit box, move the edit cursor (the vertical 
bar) to the box either by clicking in the box or tabbing to it. Any characters 
you type will be inserted at the position of the edit cursor. If the text in a 
box is currently selected, characters you type will replace that text. 

For more information on Windows text editing operations, see your 
Windows documentation. 

Buttons and Check Boxes  
Most dialog boxes have command buttons, rectangular, labeled boxes that 
look like three-dimensional buttons on many displays. The most common 
command buttons are the OK and Cancel buttons you see in dialog boxes 
to indicate whether the application should accept the information in the 
dialog box.  

Some dialog boxes have option buttons, small circles with an option name 
beside them. These buttons (also referred to in some Windows applications 
as “radio buttons”) represent mutually exclusive options, only one of which 
can be selected at a time. When an option is selected, its circle is black. 

Check boxes function as toggles to turn a setting on or off. When there is 
an X in the box next to an item, that setting is on.  

Selecting a Command Button 
Using a mouse, select a command button by clicking on it. From the 
keyboard, tab to the button and press the spacebar. For those commands 
with an underlined letter, you can type Alt plus the underlined letter. If a 
button is dim, it is currently unavailable.  
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Figure 2.15 Dialog Box with Option Buttons and Check Boxes 

Selecting an Option Button 
Using a mouse, select an option button by clicking on it. Using the 
keyboard, tab to the button that is currently on and press ↑ or ↓ to select a 
different button. For those options with an underlined letter, you can type 
Alt plus the underlined letter to turn an option button on or off. If an option 
button is dim, it is currently unavailable. 

Check Boxes 
Using a mouse, click on a check box item to turn it on or off. Using the 
keyboard, tab to a check box and press Spacebar to turn it on or off. For 
those options with an underlined letter, you can type Alt plus the underlined 
letter to turn a check box on or off.  
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Using Command-Line Switches  
You can include one or more switches in the command line you use to 
execute R&R. Using command-line switches provides a quick way of 
opening a specific library and/or report, specifying a master table for a 
blank or instant report, or loading a Dynamic Link Library (DLL) at startup. 
Figure 2.16 explains each of the command-line switches. 

Switch Purpose 
/L<library file> Specifies the report library to be opened at 

startup. Substitute the name of the library file you 
want to use for <library file>. 

/R<report name> Specifies report to be opened. Use this with the /L 
switch, substituting the name of the report you 
want to open for <report name>. 

/T<table name> Specifies that R&R create a blank report using 
<table name> as the master table. Substitute the 
full path and name of the table you want to use for 
<table name>. 

/I<table name> Specifies that R&R create an Instant Report using 
<table name> as the master table. Substitute the 
full path and name of the table you want to use for 
<table name>. 

/G Prints the report specified with /R and /L to the 
saved printer or to a disk file (if report was saved 
with a “Print to File” destination). 

/D<DLL name> Causes R&R to load the Dynamic Link Library 
(DLL) substituted for <DLL name>.   

/S<script file> Causes R&R to open and process the specified 
script file. See Chapter 5, “R&R Open Scripting,” 
of the Developing Applications manual for an 
explanation of the R&R Open Scripting interface. 
Note that use of this switch overrides the /L, /R, 
/T, and /I switches. 

Figure 2.16  Command-Line Switches 
 

 


