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Chapter 3   
Managing Reports and Libraries   

Introduction  

This chapter explains the basic procedures for creating and managing R&R 
reports, templates, and libraries and for documenting reports. This 
information is presented in the following sections:  

q Creating and Modifying Reports 
q Managing Report Libraries 
q Using R&R Report Wizards 
q Creating and Modifying Templates 

Report Definitions and Libraries 
When you create an R&R report or template, you develop a report 
definition that tells R&R how to select, analyze, summarize, and present 
data from the database files you select. You save the report definition in a 
library, a DOS file that acts as a kind of “file folder” to hold any number of 
reports. Libraries provide a convenient way of grouping related reports or 
templates.  

After you create and save a report definition, you can open it, modify it, and 
run it at any time. After modifying a report definition, you can save it again in 
the same library, save it in another library, or create a new library in which 
to save it. 

Templates 
A template is simply a report definition with a specialized purpose: to serve 
as the common starting point for a series of reports. You can create and 
modify templates the same way you do reports. By saving templates in 
libraries with RT5 extensions, you keep your templates separate from your 
reports. As a result, you can easily save, retrieve, manage, and distribute 
templates. In this chapter, explanations of procedures for managing reports 
apply also to templates, except as noted.  
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Instant Reports 
If you create a report by selecting Instant Report on the File ⇒ New 
dialog, R&R generates an Instant Report layout for you automatically. The 
Instant Report layout includes the following items: 

q All fields in the master table (or as many as will fit horizontally on 
the layout); 

q Calculated fields for master table name, date, time, page number, 
and number of records printed; 

q Grand totals of all numeric fields that have decimal places. 

In many cases, you can use the Instant Report layout as a starting point for 
creating your own layouts.  

Creating and Modifying Reports 

You develop a report by specifying the arrangement and analysis of data 
from your database. The following sections explain how to create and 
manage reports. 

Creating and Saving a Report 
The general procedures for creating and saving a report are as follows: 

1. Start R&R. By default, R&R displays a dialog (see Figure 3.1) offering 
the following options: Report Wizards, Instant Report, Blank Report, 
and Template. (Note that you can use Options ⇒ Preferences to 
specify that R&R bypass this dialog and go directly to the option that 
you choose. See Chapter 6, “Setting Defaults,” for more information.) 

2. To create a report, select Report Wizards, Instant Report, Blank 
Report or Template; then select OK. If you select Report Wizards, 
R&R will assist in the step-by-step creation of a Label, Basic 
Columnar, or Grouped Columnar report.  

 Selecting Instant Report will display the Master Table dialog.  

 If you select Blank Report, you can create a report either with or 
without a master table by turning the “Create Report Without Master 
Table” setting off (unchecked) or on (checked).  

 Selecting Report Template enables selection of a Template to use as the 
starting point for your report.  
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Figure 3.1  R&R Startup Dialog 

3. If prompted to do so, select a master table (a table that will serve as the 
initial source of data for your report) from a list of tables in the default 
Data directory (or the R&R startup directory, if no default Data 
directory has been set).   

4. Develop the report by setting database relations, inserting and 
formatting fields, specifying sorting and grouping, creating a query, and 
so on. Refer to the relevant chapters of this manual for detailed 
information about developing a report.  

5. To save the report, select File ⇒ Save to save in the current library, or 
select File ⇒ Save As to open a different library in which to store the 
report. (See the Managing Report Libraries section of this chapter 
for information about creating and selecting libraries.)  

6. Enter a name for the report. A report name can contain up to 30 
characters. Note that you cannot have duplicate report names in a given 
library. 

Modifying Reports 
After you have created and saved a report, you can open it, modify it, and 
run it at any time. You can also copy the report to another library or delete 
it when you no longer have any need for it. 
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The following sections explain how to open, copy, and delete reports. 

Opening an Existing Report  
To open a previously saved report, do the following: 

1. If a layout is currently displayed, save it if necessary. Select 
File ⇒ Open (or press Ctrl+O). The name of the current library is 
shown, and the names of the reports in that library are listed.  

2. To open a report that is in the current library, simply select the report 
from the displayed list. To open a report stored in a different report 
library, select Open Library; then select the appropriate report library 
file. 

3. Select OK. The report or template you selected is opened and 
displayed. After modifying a report, you can re-save it in the current 
library or select/create another library in which to save it.  

Copying a Report to a Different Library 
To copy a report from the current library to another library, do the 
following: 

1. Select File ⇒ Open or the Open button (or press Ctrl+O) and choose 
the report that you want to copy.  

2. Select Copy Report. Select a destination library from those listed (if 
necessary, change the drive/directory designation to choose from report 
library files in a different location). You can select any library except the 
current one as the destination library. 

3. Select OK. Enter a name for the copy (you can retain the existing name 
if no report in the destination library has that name) and select OK. 

Deleting a Report 
To delete a report, follow these steps: 

1. Select File ⇒ Open.  

2. Highlight the name of the report you want to delete (if necessary, select 
Open Library to choose from a different library) and select Delete 
Report.  

3. Select Yes to permanently erase the report; select No to cancel the 
delete.  
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Be careful about deleting reports; once you have confirmed the delete, you 
can no longer retrieve that report or template. 

Managing Report Libraries 

You can create and maintain any number of libraries in which to store 
reports. So that R&R can more easily find report library files, you may want 
to specify a default library directory using Options ⇒ File Settings (see 
Chapter 6, “Setting Defaults”).  

The following sections explain how to open or create libraries in which to 
save reports. 

Creating a Report Library 
When you save a report, you can create a new library in which to store it. 
(If you do not create a library the first time you run R&R, R&R creates a 
library named STANDARD.RP5.)  

To create a new library, first open or create a report that you want to save 
in the new library; then do the following: 

1. Select File ⇒ Save (for a newly created report that you have not yet 
saved) or File ⇒ Save As (for a previously saved report).  

2. On the Save As dialog, select New Library to display the New Report 
Library dialog. Enter a name for the new library file (up to 8 characters, 
plus a 3-character extension).  

 The default extension for report libraries is RP5. Using the default 
extension makes it easier for R&R to find the library file when you want 
to open it later. 

3. Select OK. R&R creates the library, which will then be available for 
future sessions.  

4. Either retain the current report name or enter a new name in the “Save 
Report Name” box; then select OK. Note that report names must be 
unique within a given report library. R&R stores the report in the newly 
created library under the name you specified.  
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Opening or Saving a Report in a Different Library 
When you select File ⇒ Open or File ⇒ Save As, R&R lists the reports in 
the current library. You can open or save a report in a different library by 
selecting Open Library on either the Open Report or the Save As dialog.  

Opening a Report in a Different Library 
To open a report in a library other than the current one, do the following: 

1. Select File ⇒ Open and select Open Library. The Open Report 
Library dialog displays the libraries in the default library directory (or 
the current directory, if no default library directory has been specified).  

2. Select the library containing the report you want (if necessary, change 
the drive/directory selection to display a list of libraries in a different 
location). The library you select then becomes the current library. 

3. Select the name of the report you want to open and then select OK. 

Saving a Report in a Different Library 
To save a report in a library other than the current one: 

1. Select File ⇒ Save As and select Open Library. The Open Report 
Library dialog displays the libraries in the default library directory (or 
the current directory, if no default library directory has been specified).  

2. Select a library name from those listed. Then select OK. 

3. Enter a report name in the Save Report Name edit box (for a previously 
saved report, you can retain the existing name).  

4. Select OK; the report is saved in the library you selected. 

Using R&R Report Wizards 

Report Wizards provide the capability of creating three common types of 
instant reports (Labels, Basic Columnar, or Grouped Columnar) without 
having to navigate through R&R’s menus and dialog boxes. The Wizard 
dialogs lead you through several simple steps in the preparation of each 
report type, giving you the opportunity to preview the report output. 
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Figure 3.2  Initial R&R Wizards Dialog 

To use the Report Wizards, select File ⇒ New and select “Report 
Wizards” on the New dialog. The initial R&R Wizards dialog appears (see 
Figure 3.2). To see sample output for each of the report types, right-click 
on the appropriate illustration.  

To create a report using R&R Wizards, do the following:  

1. Click on the illustration of the report type you want to create (or tab to 
the report type and press Enter).  

2. Follow the instructions on the dialog box (or in the on-line help) for 
each step of developing the report.  

 To move from one dialog to the next, select the Next button at the 
bottom; to change selections in a previous dialog, select the Back 
button. 

3. When you are done, select Finish.  

4. If you left the “Preview the report when finished” setting on (the 
default), the report preview window appears; if you turned that setting 
off, the R&R layout window appears. If necessary, you can make 
additional changes to the report in R&R before printing.  

5. Using the procedures explained earlier in this chapter, save the report in 
R&R. 

The Report Wizards make use of the R&R Open Scripting mechanism 
(explained in Chapter 5 of the Developing Applications manual) to pass a 
user-specified report specification to the main R&R executable. Visual 
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Basic source code for the R&R Report Wizards is available on request 
from Concentric Data Systems, Inc.; you can use this source code to 
modify the R&R Report Wizards or to create your own Wizards. 

Creating and Modifying Templates 

As noted previously, templates provide a convenient way of establishing 
basic report definitions that can then be used as the starting point for any 
number of reports. Procedures for creating and modifying templates are 
essentially the same as those for creating and modifying reports (except as 
noted in the following sections). However, you maintain templates in library 
files with RT5 extensions to keep them separate from your reports. 

Creating a Template Library 
Follow these steps to create a library in which to store templates: 

1. Open or create a report that you want to save as a template; then select 
File ⇒ Save As. 

2. On the Save As dialog, select New Library to display the New Report 
Library dialog. Enter a name for the new library file.  

3. Enter RT5 for the file extension and select OK. R&R creates the 
template library, which will then be available for future sessions. 

4. Enter a name for the template in the “Save Report Name” box; then 
select OK. Note that template names must be unique in a given library. 
R&R stores the template in the newly created template library under the 
name you specified. 

Creating and Saving a Template 
General procedures for creating and saving a template are as follows: 

1. Start R&R. Select the appropriate item to either create a report or open 
an existing report. If you are creating a new report, select a master table 
(if prompted to do so). 

2. Develop or modify the report as necessary.  

3. Select File ⇒ Save As. On the Save As dialog, select Open Library (to 
save to an existing template library) or New Library (to create a 
template library).  
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4. Open the “List Files of Type” box and select Templates (RT5). Either 
enter or select the name of a template library in which to save the 
template; then select OK. 

5. Enter a name for the template in the “Save Report Name” box and 
select OK. 

Modifying a Template 
After you have created and saved a template, you can open, modify, or 
copy it at any time. You can also use a template as the starting point for a 
report (or for another template). 

The following sections explain how to open, modify, and use templates. 

Opening and Modifying an Existing Template  
To open and modify a previously saved template, do the following: 

1. If a layout is currently displayed, save it if necessary. Select File ⇒ 
Open (or press Ctrl+O). The name of the current library is shown, and 
the names of the reports in that library are listed.  

2. Select Open Library; then select the appropriate template library file 
(extension RT5) and select OK. 

3. Select a template from those listed and select OK to open and display 
the template. On the title bar, “Template” is included in parentheses 
after the template name to clearly indicate that you are editing a 
template, not a report. 

4. Modify the template as necessary. Select File ⇒ Save to save the 
template in the library from which you retrieved it. If necessary, you can 
select/create another template library in which to save it. 

Copying a Template to a Different Library 
To copy a template from its original library to another library, do the 
following: 

1. Select File ⇒ Open or the Open button (or press Ctrl+O).  

2. Select Open Library and select the appropriate template library. Then 
select the template that you want to copy.   
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3. Select Copy Report. Select a destination library from those listed (if 
necessary, change the drive/directory designation to choose from 
template library files in a different location). Remember that template 
libraries have RT5 extensions 

4. Select OK. Enter a name for the copy (you can retain the existing name 
if no template in the destination library has that name) and select OK. 

Deleting a Template 
To delete a template, follow these steps: 

1. Select File ⇒ Open.  

2. Select Open Library and select the appropriate template library. Then 
select the template that you want to delete.   

3. Select Yes to permanently erase the template; select No to cancel the 
delete.  

Be careful about deleting templates; once you have confirmed the delete, 
you can no longer retrieve that template. 

Using a Template to Create a Report 
After you have created and saved a template, you can retrieve it to use as 
the basis for one or more reports.  

To use a template to create a report, do the following: 

1. Select File ⇒ New. On the startup dialog, select Template. 

2. R&R lists the templates in the default template library, if one has been 
defined (see Chapter 6, “Setting Defaults,” for information about setting 
a default template library). If no default template library has been 
defined, templates in the last selected template library are listed. If 
necessary, change the drive/directory designation to select a library in 
another location.  

3. Select the template that you want to use as the starting point for your 
report and select OK.  

4. Modify the report definition as necessary. When you are done, select 
File ⇒ Save; R&R displays reports in the current report library (if 
necessary, you can open or create another report library in which to 
save the report). Enter a report name and select OK. 
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Documenting Reports and Templates 

To document the content and layout of a report or template, you can attach 
a brief explanatory comment, as well as display or print a report 
specification, which provides a complete description of the report or 
template.  

Adding a Comment to a Report or Template 
To add a brief comment to a report or template, do the following: 

1. Open the report or template and select File ⇒ Summary Info.  

2. In the Comments box, enter a text explanation (up to 100 characters) to 
be attached to the report or template.   

3. When you save the report or template, the comment is saved with it and 
is included as part of the report/template specification.  

Printing a Report Specification 
This report specification includes the following information: 

q Name and location of the R&R report library; 
q The report comment (if any); 
q Print, page layout, and record layout settings; 
q Names and locations of master table and index, related table(s) and 

index(es), and text memo file (if any); 
q Scope and Query (if any);  
q Position, width, data type, format, font, trim setting, and color of all 

fields on the layout;  
q Names and sizes of all fonts used in the report; 
q Names, locations, sizes, and scaling settings of bitmapped images; 
q For vertical and horizontal lines:  size, thickness, and color; 
q For boxes:  size, border thickness and color, foreground and 

background color, number of included sides, and pattern; 
q Names and expressions of all calculated and total fields; 
q Any conditional line printing settings; 
q Sort/group field selections and settings; 
q Windows International settings in effect for the current report; 
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q Database memo editor and default file extensions. 

To print or display a report specification, do the following: 

1. Select File ⇒ Print. In the “Print What” list box, select Report 
Specification.  

2. On the Print dialog, you can either select Preview to display the 
specification or select OK to send the specification to the printer (or to 
print to a file, if you have specified an output file in the Print to File box). 

3. The specification is output to the selected destination. For printed 
output, whenever possible R&R uses a fixed-pitch font on the current 
printer. 

 

 


