
 
 

Using 
R&R 

Report Designer 
 SQL 

 Version 10 
 



 
COPYRIGHT 

 
©2002 Liveware Publishing Inc. 

 
All rights reserved. 

 
Liveware Publishing Inc. 

1406 Society Drive 
Claymont, DE 19703 

 
This manual is copyrighted and all rights are reserved. This 
document may not, in whole or part, be copied, photocopied, 

reproduced, translated, or reduced to any electronic medium or 
machine readable form without the prior written consent of 

Liveware Publishing Inc. 
 

Printed in the United States of America 
 

Trademarks and Acknowledgments 
 

R&R Report Writer is a trademark of 
Liveware Publishing Inc. 

 
Portions of the imaging technology of this product are copyrighted by 

Accusoft Corporation. 
 

All Avery product code numbers are trademarks of the 
Avery Dennison Corporation. 

 
All other product names and logos in this manual are used for 

identification purposes only and may be trademarks or registered 
trademarks of their respective companies. 

 



Using Report Designer 
Chapter 1    Using Menus and Dialogs 
Introduction (Using Menus and Dialogs) 
R&R for SQL Report Designer is an information access and reporting tool that 
enables you to produce custom reports to select, analyze, summarize, and present 
data from your tables in a variety of ways. After you have developed a custom 
report, you can display it on screen or print it with any combination of fonts and 
print styles that your printer supports.  

This chapter describes all components of the Report Designer window and explains 
commands and dialog boxes. This information is presented in the following sections: 

� Understanding the Main Window  

� Selecting from Menus  

� Using Report Designer Dialog Boxes  

� Using Command-Line Switches  

 

Understanding the Main Window 

Understanding the Main Window 

When you run Report Designer, the startup dialog displays. After you have selected 
a report to edit or a starting point for creating a new report, the main window 
appears. This window contains the following components: 

� A Title Bar; 

� A Menu Bar containing File, Edit, View, Insert, Format, Options, 
Database, Calculations, and Help selections; 

� A Standard Toolbar of buttons for running Report Designer commands;  

� A Formatting Toolbar of buttons and edit boxes for formatting fields 
and specifying other layout settings;   

� A Work Space with horizontal and vertical rulers; 

� A Status Bar.  

In addition, the window includes an edit cursor, a blinking vertical line that shows 
the insertion point for placing objects. Figure 1.1 illustrates a sample window. 

You can access all commands from the Menu Bar; the Toolbars give you quick 
access to commonly used commands. When you position the cursor over each of 
the Toolbar buttons, a ToolTips help label appears explaining its purpose. 

You can display Report Designer in a maximized window or re-size the window as 
necessary. To re-size the window, follow the procedures in your Windows 
documentation.  
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Figure 1.1  Main Window 

 

Using the Menu Bar 

The Menu Bar contains the "top-level" commands: File, Edit, View, Insert, Format, 
Options, Database, Calculations, and Help. You can select a command on this menu 
in any of the following ways: 

� Click on it;  

� Type Alt plus the underlined letter in the command;  

� Press F10, use the cursor keys to highlight the command, and press 
Enter.  

Selecting any one of these commands displays a menu of additional commands that 
open dialog boxes or perform specific actions on selected objects or lines. See the 
Selecting from Menus section for a summary of each command menu.  

 

Using the Standard Toolbar 

For many commands, you can select a Standard Toolbar button instead of selecting 
from the Menu Bar (use View  ⇒ Toolbars to turn the Standard Toolbar display on 
or off). Clicking on one of these buttons either executes a command or opens a 
dialog in which you can select or change various options.  

Figure 1.2 identifies the Menu Bar command (and associated shortcut key if 
applicable) that corresponds to each Standard Toolbar button. 

Toolbar 
Button 

Menu Bar 
Command 

Shortcut  
Key 

  
File  ⇒ New Ctrl+N 

  
File  ⇒ Open Ctrl+O 
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File  ⇒ Save Ctrl+S 

  
File  ⇒ Print Ctrl+P 

  
File  ⇒ Print Preview  

  
Edit  ⇒ Cut Ctrl+X 

  Database  ⇒ View Result Set  

  File  ⇒ Export  

  
Edit  ⇒ Copy Ctrl+C 

  
Edit  ⇒ Paste Ctrl+V 

  
Insert  ⇒ Line  

  
Insert  ⇒ Box  

  
Insert  ⇒ Picture  

  
Insert ⇒ Chart  

  
Database  ⇒ Master Table  

  
Database  ⇒ Relations  

  
Database  ⇒ Sort Order  

  
Database  ⇒ Group Order  

  
Database  ⇒ Filter  

  
Calculations  ⇒ Calculated Field  

  Calculations  ⇒ ParameteRR Field   

  
Calculations  ⇒ Total Field  

Figure 1.2  Toolbar Buttons and Corresponding Commands 
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Using the Formatting Toolbar 

Using the Formatting Toolbar 

The Formatting Toolbar (see Figure 1.3) that optionally displays below the Standard 
Toolbar provides a quick way of formatting fields and text in your report. After you 
select one or more items on the report layout, you can specify font, point size, 
style, and alignment by using the list boxes and buttons on this bar.  

In some cases you may want to hide the Formatting Toolbar — for example, if you 
want to display more of the report layout without having to scroll. You use View  ⇒ 
Toolbars to control display of the Formatting Toolbar. Click the check box next to 
"Formatting" to turn the bar on (checked) or off (empty). 

  
Figure 1.3  Formatting Toolbar 

Figure 1.4 briefly explains each item on the Formatting Toolbar.   

Toolbar Item Purpose 

Font Apply a font to one or more selected 
fields 

Size Select or enter a size for the current font 

Style Buttons B for Bold, I for Italic, U for Underline 

Alignment 
Buttons 

Non-word-wrapped fields:  Left, Center, 
Right; word-wrapped fields:  Left, Right, 
Justified 

Trim Button Turns automatic trim on or off 

Trashcan Button Deletes currently selected item(s) or 
restores most recently "trashcanned" 
item(s) 

Auto/Freeform 
Button 

Toggles between Automatic/Freeform 
line height (see Chapter 3, "Working 
with Bands") 

Snap-To-Grid 
Button 

Turns snap-to-grid on or off 
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Toolbar Item Purpose 

Suppress Record Lines Toggles between display/non-display of 
record band lines 

Compress 
Record/Group Lines 

Toggles between display/non-display of 
record lines that contain only empty 
fields 

Field Names Toggles between display of fields as field 
names or format symbols 

Figure 1.4  Formatting Toolbar Items 

 

Using the Bold, Italic, and Underline Buttons 

The style and underline buttons (B, I, and U) serve as toggles that turn each style 
on or off. For example, to make a selected item bold, click the Bold button. To 
remove the bold style, click the same button. The item’s representation on the 
layout changes to indicate the selected style. You can apply more than one style to 
the same item. (Bold or Italic will print only if available for the currently selected 
font.) 

 

Using the Alignment Buttons 
Report Designer assigns a default alignment to each field when it is inserted 
on the layout. The default alignment is based on the field’s data type: 

� Numeric fields are right-aligned; 

� Memo fields are word-wrapped, left-aligned; 

� All other fields are left-aligned.  

To find out the alignment of any field on the layout, select it; on the Formatting 
Toolbar, the button for the current alignment will be "pressed in." (Note that for 
character and memo fields, the first character of the field symbol represents the 
field’s alignment.)  

To change field alignment, select the field and click one of the alignment buttons 
(Align Left, Center, Align Right, or Justify). You can also use the Alignment tab; to 
access the Alignment tab, select the field and press F9 (or right-click on the field 
and select Properties); then select the Alignment tab.  

See Chapter 4, "Working with Fields," for more information about alignment and 
alignment symbols. 

 

Using the Other Formatting Buttons 

The remaining items on the Formatting Toolbar provide quick access to common 
formatting and editing tasks: 
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� The Trim button controls automatic trimming of blank space between 
fields on the same line. You can also control trim using the Alignment tab 
(select Format ⇒ Properties, then select the Alignment tab).  

� The Trashcan button provides a quick way of clearing selected objects 
or restoring the most recently "trashcanned" item(s).  

� The Auto/Freeform button toggles between Auto and Freeform line 
height type for a line or group of lines (see Chapter 3, "Working with Bands," 
for an explanation of Automatic and Freeform line height). 

� The Snap-To-Grid button turns snap-to-grid on or off.  

� The Suppress Record Lines button toggles between display/non-display 
of record band lines.  

� The Compress Record/Group Lines button toggles between 
display/non-display of record band lines that contain only empty fields.  

� The Field Names button toggles between display of fields as field 
names or format symbols.  

�  

Changing Horizontal and Vertical Ruler Settings 

Changing Horizontal and Vertical Ruler Settings 

Calibrated horizontal and vertical rulers help you place fields, text, and objects at 
specific positions on the report layout. For example, if you type a left-justified 
column heading on the layout immediately under the 1 inch position on the 
horizontal ruler, this column heading will begin printing one inch from the left 
margin of your report.  

The left, right, or center alignment point for a selected item is marked by a location 
indicator on the horizontal ruler. Vertical position is marked by a darkened band in 
the Band Area. 

The default setting for both the Horizontal and the Vertical Ruler Spacing is 10; you 
can select a setting from 4 through 30. This setting controls the number of ruler 
increments per inch on each ruler. Note that the Ruler Spacing settings control only 
the spacing of the report layout rulers (since the fonts actually applied to fields in 
the report control the print spacing). 

When the grid is turned on, the ruler settings determine the horizontal and vertical 
grid spacing for Freeform lines. For Automatic lines, the horizontal ruler setting 
determines the horizontal grid spacing; the vertical grid spacing is determined by 
the height of the largest font on each line. See Chapter 3, "Working with Bands," for 
an explanation of Automatic and Freeform line height. 

To change the calibration of the rulers, right-click on either ruler or press F8 to 
display the Ruler Spacing dialog (see Figure 1.5). 
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Figure 1.5  Ruler Spacing Dialog Box 

Using the Horizontal or Vertical Spacing slider control, select a ruler spacing from 4 
through 30 units per inch. Specify a lower number to display a coarser ruler scale; 
specify a higher number to display a finer ruler scale.  

You can use either the mouse or the keyboard to change ruler settings: 

� Click to the left or right of the slide pointer to decrease 
(left) or increase (right) the setting by 4 units at a time. 
Drag the slider to change the setting in 1-unit 
increments. 

� Use the left or right cursor key to decrease (left) or 
increase (right) the setting by 2 units at a time. Use 
Page Up or Page Down to decrease (PgUp) or increase 
(PgDn) the setting by 4 units at a time. 

 

Work Space 

Work Space 

The area below the horizontal ruler line is the Work Space in which you create 
report layouts. The Work Space is divided into two main areas: 

� The Band Area — the area to the left of the screen, which identifies the 
type and status of every band line on the layout. This area can be optionally 
displayed using a color-coding schema as well as the standard text-based 
band-type indication. 

� The Layout Area — the large area on the right in which you create a 
report layout, a schematic representation of your report that contains the 
fields, text, and other objects that will appear on your report.  
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You can adjust the relative sizes of the Band and Layout areas using the "splitter 
bar" between them. Click and drag the splitter bar to the right to increase the Band 
Area and decrease the Layout Area; drag the splitter bar to the left to decrease the 
Band Area and increase the Layout Area.   

 

Band Area 

The Layout Area consists of one or more bands, each with characteristics that 
define how the data in that band will be presented when the report is run. As Figure 
1.1 on page 4 illustrates, the Band Area contains a band-type indicator for each 
band in the Layout Area. Band-type indicators, which Report Designer automatically 
displays when you create, insert, or move lines, identify whether a line is part of the 
report’s Title, Page Header, Group Header, Record band, Group Footer, Summary 
band, or Page Footer. The name of the band type will always be displayed (just 
once per band type) on the bottom-most band of that type. For example, if you 
have three Record band lines on the layout, the third one will contain the text 
"Record." To make it easier to visualize bands by type, you can enable the display 
of color-coded band lines using the Options  ⇒ Preferences dialog. To select one or 
more lines, click or drag the mouse in the Band Area.  

The narrow channel at the right edge of the Band Area is the Line Status Area. This 
area provides the following information: 

� Up and down arrows in the Line Status Area indicate the top and 
bottom border of any Freeform line (for a full explanation of Freeform lines, 
see Chapter 3, "Working with Bands").  

� A question mark indicates that a logical field has been assigned to 
control printing of that line. (See Chapter 3, "Working with Bands," for 
information about controlling line printing with logical fields.) 

�  

Layout Area 

The Layout Area typically contains text, which will appear in the report exactly as 
typed, and data fields, which are represented on the layout either by field symbols 
such as <xxxxxx (character data) and 99999 (numeric data) or by field names (if 
the Field Names setting has been enabled on the View menu). This area can also 
contain lines, boxes, bitmapped graphic images, and other objects. 

The Layout Area can be scrolled both vertically and horizontally. You can create 
report layouts up to a maximum of 256 lines; the maximum layout width is 
determined by the page layout settings. You will see an R on the Horizontal Ruler 
that represents the position of the right margin. The area to the right of the margin 
indicator is shaded gray. You can place fields within the gray area; however, those 
fields might not display on a printed page depending on your printer settings. To set 
the right margin, select File  ⇒ Page Setup. 

See Chapter 4, "Working with Fields," for information about adding text and fields 
to a report layout. See Chapter 12, "Adding Lines, Boxes, and Shading," for 
information about drawing lines and boxes. For an explanation of inserting and 
sizing images, see Chapter 15, "Inserting Bitmapped Images." 
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Using the Status Bar and Scroll Bars 

Using the Status Bar and Scroll Bars 

Immediately below the Work Space is the Status Bar, which displays information 
about current operations and/or the position of a selected item. At the bottom and 
right of the main window are the horizontal and vertical scroll bars, which enable 
you to scroll the Work Space up and down, left and right. 

 

Status Bar 

When you are working in the Layout Area, the Status Bar identifies the position of 
the edit cursor on the layout and indicates whether the "Caps Lock" or "Num Lock" 
key on your keyboard is on. In addition, the Status Bar may contain descriptions of 
command options, prompts telling you what action to take, or information about the 
currently highlighted field.  

 

Scroll Bars 

Use the horizontal and vertical scroll bars to scroll the Work Space. Both the Band 
Area and the Layout Area can be scrolled vertically. However, only the Layout Area 
can be scrolled horizontally, since the information in the Band Area is relevant to 
the entire width of the report layout. For information about scrolling an application 
window, see your Windows documentation. 

 

Selecting from Menus 

Selecting from Menus 

You execute commands by selecting from menus or clicking buttons and then using 
dialog boxes to provide additional information required by some commands. 
Operation of Report Designer menus and dialog boxes follows the Windows 
conventions explained in the following sections.  

The Menu Bar is the main menu, from which you select the command menus you 
want to use. For example, selecting File in the Menu Bar will display the File menu. 
You can open a command menu from the Menu Bar in any of the following ways: 

� Click on the command name; 

� Press F10 (or Alt) and type the accelerator key for the command (the 
underlined letter in the command name — for example, F for File or E for 
Edit);  

� Press F10, use the cursor keys to highlight a command name, then 
press Enter. 
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After opening a command menu, you can select a command from that menu in any 
of these ways: 

� Click on the command name; 

� Type the accelerator key for the command; 

� Use the cursor keys to highlight a command; then press Enter. 

For example, after opening the File menu, you can select "New" by clicking on it, by 
typing N, or by highlighting the command and pressing Enter. Cancel a command 
selection by clicking outside the menu box or by pressing Esc. 

You can also execute some commands directly from the keyboard, without using 
the Menu Bar, by typing a shortcut key combination. For example, you can execute 
Format ⇒ Properties by pressing F9.  

At some points, one or more commands on the Menu Bar or in the command menus 
will be dim, indicating that they are not available.  

 

File Menu 
Use the File menu to do the following: 

� Create, open, close, save, print, or preview a report; 

� Enter or edit comments for the current report; 

� Define the page setup;  

� Manage data source connections; 

� Export a report to an Active X Viewer, HTML, plain text, database, 
result set database, worksheet, text data, Rich Text Format (RTF), or Word 
Merge file or to an Excel 5.0 PivotTable or Chart; 

� Send a report via email; 

� Exit Report Designer. 

Selecting File displays a menu of choices; selecting a choice either opens a dialog or 
executes a command. Figure 1.6 summarizes the actions these menu choices 
perform.  

Command Purpose 

New (Ctrl+N) Create an Auto-SQL report (Report 
Designer will dynamically define the SELECT) 

New User-SQL Create a User-SQL report (the user directly 
enters the SELECT) 

Open (Ctrl+O) Open or delete report; copy report to 
another library; select a library  

Close Close Report 

Data Source 
Connections 

Connect and disconnect data sources 
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Command Purpose 

Save (Ctrl+S) Save a report 

Save As Save a report with a different name or in a 
different library 

Properties Enter comments for current report 

Page Setup Specify paper size, margins, orientation 

Print Preview Display the current report on the screen 

Print (Ctrl+P) Print using the current printer, select a 
different printer, or change print options 

Export Output report data to a plain text, 
database, worksheet, text data, RTF, or 
Word merge file or to an Excel 5.0 
PivotTable or Chart 

Send Send a report via email 

Exit (Alt+F4) Leave Report Designer and return to 
Windows 

Figure 1.6  File Menu Choices   

Note that the Page Setup settings for paper size, margins, and orientation apply 
only to the current report and are saved with it. 

 

Edit Menu 

The Edit menu provides choices for modifying reports — cutting and pasting, 
copying, deleting, moving, and so on. Figure 1.7 summarizes the purpose of each 
Edit menu choice.   

Command Purpose 

Undo (Ctrl+Z) Undo Last Clear (or Last Move) 

Cut (Ctrl+X) Remove selected item(s) and save to 
memory 

Copy (Ctrl+C) Copy selected item(s) to memory 

Paste (Ctrl+V) Paste item(s) saved to memory 

Clear Erase selected object(s) 

Paste Clipboard Image Paste graphic image from clipboard 

Paste Special Link or embed an object from the 
clipboard 

Move Fields (F7) Move selected field(s) or band line(s) 
using cursor keys 

Duplicate Fields Copy selected field(s) for movement 
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(Shift+F7) using cursor keys 

Links Display and modify existing links in a 
report 

Object Modify the selected OLE object 

Figure 1.7  Edit Menu Choices     

 

View Menu 

View Menu 

Use the View menu to do the following: 

� Turn Standard Toolbar display on or off; 

� Turn Formatting Toolbar display on or off; 

� Turn ToolTips display on or off; 

� Turn horizontal or vertical ruler on or off; 

� Turn grid display on or off; 

� Display fields either as symbols or as field names.   

By default, the Toolbars and rulers are displayed; fields are represented by symbols 
on the layout; and the grid is shown. To change these settings, select View; then 
select the item to change.   

Command Purpose 

Toolbars Hide or show the Standard and Formatting 
Toolbars; enable or disable ToolTips 
display 

Horizontal Ruler Hide or show the horizontal ruler 

Vertical Ruler Hide or show the vertical ruler 

Grid Hide or show the grid 

Field Names Display fields as symbols or as names 

Figure 1.8  View Menu Choices 

 

Toolbar and ToolTips Settings 

A check mark next to either "Standard" or "Formatting" on the Toolbars dialog 
means that the item is currently displayed. To turn off display of either, select the 
appropriate item.   

A check mark next to the "ToolTips" item on this dialog means that a help label will 
display when you position the cursor over one of the toolbar items. To turn off 
display of these labels, click the box to remove the check mark. 
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Horizontal and Vertical Rulers 

To turn on or off the display of the horizontal or vertical ruler, select Horizontal 
Ruler or Vertical Ruler. A check mark next to either indicates the ruler is currently 
visible.  

 

Grid 

To help you align objects on the report layout, you can enable a grid consisting of a 
series of dots. The grid spacing is determined by the settings for the horizontal and 
vertical rulers. To control the grid display, select View ⇒ Grid; a check mark 
appears when this setting is on. When the Snap-To-Grid setting is on, items that 
you insert or move will "snap" to the nearest grid mark. See the Format Menu 
section of this chapter for information about turning the Snap-To-Grid setting on or 
off.  

 

Field Names 

Fields can be represented on the layout either by field names or by symbols (such 
as >xxxxx) that identify field type and alignment. By default, each field is 
represented by symbols. To display field names instead, turn on the View ⇒ Field 
Names setting. As a result, each field’s name is shown at the field’s location 
(depending on field width, the entire name may not appear).  

 

Insert Menu 

Insert Menu 

Using the Insert menu choices, you can insert fields from the composite record 
structure (the set of fields available for use in a report, including master and related 
table fields and any Report Designer total or calculated fields), create and insert 
new band lines, attach a text file to provide memo fields for the report, and insert 
lines, boxes, or images. (See Chapter 17, "Creating Form Letter Reports," for 
information about preparing, attaching, and using a text memo file.) Figure 1.9 
briefly explains the Insert menu commands. 

Command Purpose 

Field (Ins, F11) Insert field from composite record structure 

Band Line 
(Shift+F11) 

Insert line of same type above current line 

Create Band Line 
(Ctrl+F11) 

Insert one or more lines of any band type 

Text File Insert text memo file 

Line Draw horizontal or vertical line 
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Box Draw box or add shading 

Picture Insert bitmapped graphic image 

Chart Insert chart 

Object Insert an OLE object 

Figure 1.9  Insert Menu Commands  

 

Format Menu 

Format Menu 

The Format menu choices enable you to control the format and alignment of fields 
and lines, specify record formatting options, change ruler settings, and turn snap-
to-grid on or off. Figure 1.10 lists the commands and explains the purpose of each. 
See Chapter 4, "Working with Fields," for more information about these commands.  

Command Purpose 

Font (F5) Specify typeface, size, and style 

Properties (F9) For selected band line(s):  Control line 
height and logical conditions; for selected 
field(s):  Modify format (width, number 
of integers and decimals, numeric 
format, etc.), alignment, trim, field 
comment 

Band Line Justify Align all fields on selected lines 

Record Layout Specify various record formatting options 

Rulers (F8) Change horizontal/vertical ruler spacing 

Snap To Grid  
(Shift+F8) 

Turn snap-to-grid on and off 

Figure 1.10  Format Menu Choices  

The Record Layout dialog provides settings for formatting the Record and Summary 
bands of a report, including selections for multiple and "snaked" columns, Avery 
labels, and number of record copies.  

 

Options Menu 

Options Menu 

The Options menu includes the following choices: Preferences, Default Settings, File 
Settings, and Data Source (see Figure 1.11).   

Command Purpose 
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Preferences Turn scroll bars on and off; enable colors 
for band area/preview; enable colors for 
total and group field dialogs; control result 
of selecting File  ⇒ New; specify memo 
editor; specify display of field names, report 
dictionary descriptions, or both in field lists; 
Display sorted field names 

Default Settings Set paper size, margins, font, spacing, 
logical strings 

File Settings Specify default report image and template 
folders; default text file extensions;  

Chart Settings Specify defaults for Font and Palette for 
charts 

Data Source Specify a default data source and control 
access to data sources from Report 
Designer 

Figure 1.11  Options Menu Choices   

You use the Preferences dialog box to control the display of horizontal and vertical 
scroll bars and to specify what action Report Designer will take when you select File  
⇒ New. See Chapter 5, "Setting Defaults," for more information about the 
Preferences dialog.  

The Default Settings dialog controls global settings for paper size, margins, font and 
point size, font color, ruler spacing, logical strings, and snap-to-grid. These settings 
apply to all new reports. The Default File Settings dialog enables you to set default 
data, library, and image directories; specify default file extensions for text memo 
and image files; and specify a default report dictionary and report dictionary index.   

Select Options ⇒ Data Source to specify defaults to control access to your data 
sources. You can change the data source defaults at any time during a Report 
Designer session. 

See Chapter 5, "Setting Defaults," for more information about changing defaults 
using these dialogs. 

 

Database Menu 

Database Menu 

Use the Database menu choices to specify the tables from which data will be drawn 
for a report, to sort and group that data, to create filters that select specific 
records, to display the SQL SELECT statement for the current report, and to define a 
data governor to limit the number of rows retrieved from the database while you 
are designing a report. Figure 1.12 summarizes the Database choices for an Auto-
SQL report. 
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Command Purpose 

Master Table Select or change master table (Auto-SQL reports only) 

Joins Select, edit, and remove table joins 

Sort Order Select fields to control report sort order 

Group Order Select fields to group report data 

Filter Specify selection conditions to filter records 

Show SQL Display SQL SELECT statement; copy SELECT 

Limit Result Specify maximum number of rows to retrieve 

View Result Set View all fields used in the report in a database browser 
window. 

Figure 1.12  Database Menu Choices 

For User-SQL reports, the Database menu choices differ slightly. See Chapter 6, 
"Selecting Data," and Chapter 18, "Creating User-SQL Reports," for information 
about Auto-SQL and User-SQL reports. 

 

Calculations Menu 

Calculations Menu 

The Calculations menu choices enable you to create and edit calculated fields, total 
fields, ParameteRR fields, and User-Defined Functions (UDFs), as well as purge a 
report of any unused total and/or calculated fields.   

Command Purpose 

Calculated Field Create and edit calculated fields 

Total Field Create and edit total fields 

ParameteRR Field Create a field whose final value will be 
determined at report execution time 

User Function Create and edit User-Defined functions 

Auto Total Create totals for all selected fields 

Purge Calculations Remove all unused fields 

Figure 1.13  Calculations Menu Choices   

You use the Calculated Fields dialog box to create fields whose values are computed 
as a report is generated, rather than being retrieved from the database. You use 
the Total Fields dialog to create fields that contain summary information such as a 
subtotal or grand total figure; Report Designer calculates the value of such a field 
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according to the total options you select. You can create total and calculated fields, 
insert them in reports, and manipulate them just as you do data and text fields. 

You use the ParameteRR Fields dialog to create fields whose values can be modified 
via a ParameteRR Value Entry screen when the report is executed. 

To edit a total, calculated, or ParameteRR field that has been inserted on the layout, 
simply select the field and press F2 to display the Edit Total, Edit Calculation, or Edit 
ParameteRR dialog box. 

You use the User Function dialog to create UDFs to process data according to an 
expression or formula that you define. You can create UDFs to perform complex 
operations and then use those UDFs in calculated field expressions in any report.  

The Auto Total dialog enables you to select multiple fields on the layout and have 
Report Designer automatically create totals for those fields and insert the totals on 
a new band line. 

Use the Purge Calculations command to remove any unused total, calculated fields, 
or ParameteRR fields from the report definition. Removing unused fields can speed 
up report generation and reduce the amount of memory required. 

 

Using Report Designer Dialog Boxes 

Using Report Designer Dialog Boxes 

Like other Windows applications, Report Designer uses dialog boxes to request and 
display information related to a specific command.  

Many of the dialog boxes in Report Designer are standard Windows dialog boxes. 
For example, the File  ⇒ New dialog box is like the File New dialog in many 
Windows applications.  

Other dialog boxes are unique to Report Designer, since they request information 
specific to report generation. For example, the Database  ⇒ Filter dialog box 
requests information that enables Report Designer to construct a filter selecting 
specified records for a report.  

You can move around in a dialog box using either the mouse or the keyboard. Using 
a mouse, simply click on any option to make it active. Using the keyboard, tab from 
option to option or press Alt plus the underlined letter in the option you want to 
select. When an option is active, it is marked by a highlight or dotted rectangle. 

 

List and Edit Boxes 

List and Edit Boxes 

A list box is any vertical list from which you select a setting, file, or other item. 
Many dialog boxes contain edit boxes in which you can enter text such as paths, file 
names, field names, or numeric values. In some cases, an edit box and list box are 
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combined so that you can either select from the list or type your choice in the edit 
box (such boxes are sometimes referred to as "combo boxes").  

 

List Boxes 

Some list boxes open automatically when you select a command or item; on some 
dialog boxes, you must first click the scroll arrow next to an item to open a list box 
containing choices for that item. To select a choice from a list box, either click on 
the choice or use the cursor keys to highlight it. From the keyboard, you can select 
a field from a field list box by typing the first letter of the field name until the field 
is highlighted on the list.  

Note that the complete field name (or the report dictionary comment for that field, 
if there is one) is displayed in the Status Bar when a field is highlighted in the field 
list box. 

 

Edit Boxes 

To enter or modify text in an edit box, move the edit cursor (the vertical bar) to the 
box either by clicking in the box or tabbing to it. Any characters you type will be 
inserted at the position of the edit cursor. If the text in a box is currently selected, 
characters you type will replace that text. 

For more information on Windows text editing operations, see your Windows 
documentation. 

 

Buttons and Check Boxes 

Buttons and Check Boxes 

Most dialog boxes have command buttons: rectangular, labeled boxes that look like 
three-dimensional buttons on many displays. The most common command buttons 
are the OK and Cancel buttons you see in dialog boxes to indicate whether the 
application should accept the information in the dialog box.  

Some dialog boxes have option buttons: small circles with an option name beside 
them. These buttons (also referred to in some Windows applications as "radio 
buttons") represent mutually exclusive options, only one of which can be selected at 
a time. When an option is selected, its circle is black. 

Check boxes function as toggles to turn a setting on or off. When there is an X in 
the box next to an item, that setting is on.   
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Selecting a Command Button 

Using a mouse, select a command button by clicking on it. From the keyboard, tab 
to the button and press the spacebar. For those commands with an underlined 
letter, you can type Alt plus the underlined letter. If a command button is dim, it is 
currently unavailable.  

 

Selecting an Option Button 

Using a mouse, select an option button by clicking on it. Using the keyboard, tab to 
the button that is currently on and press ↑ or ↓ to select a different button. For 
those options with an underlined letter, you can type Alt plus the underlined letter 
to turn an option button on or off. If an option button is dim, it is currently 
unavailable. 

 

Check Boxes 

Using a mouse, click on a check box item to turn it on or off. Using the keyboard, 
tab to a check box and press Spacebar to turn it on or off. For those options with an 
underlined letter, you can type Alt plus the underlined letter to turn a check box on 
or off.  

 

Figure 1.14  Dialog Box with Option Buttons and Check Boxes 
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Using Command-Line Switches 

You can include one or more switches in the command line you use to execute 
Report Desinger. Using command-line switches provides a quick way of opening a 
specific report, specifying a master table for creation of a blank or instant report, or 
loading a Dynamic Link Library (DLL) at startup. Figure 1.15 explains the command 
switches. 

Switch Purpose 

/L<library file> Applies only to reports that have been saved 
in a report library file. Specifies the report 
library containing the report identified with 
the /R switch. Substitute the name of the 
library file for <library file>. 

/R<report 
name> 

Specifies the report to be opened. Substitute 
the name of the report you want to open for 
<report name>. Can be used in conjunction 
with /L to open a report from a library. 

/T<table name> Specifies that Report Designer create a blank 
report using <table name> as the master 
table. Substitute the full path and name of the 
table you want to use for <table name>. 

/I<table name> Specifies that Report Designer create an 
Instant Report using <table name> as the 
master table. Substitute the full path and 
name of the table you want to use for <table 
name>. 

/G Prints the report specified with /R to the saved 
printer or to a disk file (if the report was 
saved with a "Print to File" destination). 

/D<DLL name> Causes Report Designer to load the Dynamic 
Link Library (DLL) substituted for <DLL  
name>.  You can use this switch to improve 
performance of reports containing calculated 
fields that use the CDLL() function. 

/S<script file> Causes Report Designer to open and process 
the specified ReportScript file. Note that use 
of this switch overrides the /L, /R, /T, and /I 
switches. 

Figure 1.15  Command-Line Switches 
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