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Chapter 1
Introduction to Report Writer  

This chapter explains Report Writer reports and identifies the elements of a typical report. 
This information is presented in the following sections:

q What Is a Report Writer Report?

q How Does Report Writer Produce a Report?

Report Writer is a data access and reporting tool that enables you to produce custom reports 
to select, analyze, summarize, and present data from your tables in a variety of ways. After 
you have developed a custom report, you can display it on screen or print it with any 
combination of fonts and print styles that your printer supports. 

The Report Writer documentation contains information for both beginning and experienced 
users of Report Writer. Both the print and the on-line documentation assume that you have 
a working knowledge of standard Windows mouse and keyboard actions and that you know 
the directory location of your data files.

The documentation consists of three printed manuals and a complete on-line help reference:  

• Getting Started (the manual you are reading) contains installation and configuratio
instructions, a brief tutorial, and a selection of sample report layouts with 
accompanying explanations. 

• Using Report Writer is a task-oriented guide to all interactive Report Writer 
functionality.

• Developing Applications, intended for developers, is a complete reference guide for 
the Report Writer Runtime and includes information about incorporating Runtime
reports in database applications.

• On-line help is available at any time when you are running Report Writer. Depen
on what you are doing, you can press F1, select Help from the Menu Bar, or sele
Help button on a dialog box.
Getting Started with Report Writer, Xbase Edition 1-1
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What Is a Report Writer Report?
A Report Writer report is a custom layout and presentation of data drawn from one or more 
tables. This layout can take the form of a customer list, sales analysis, invoice, form letter, 
mailing labels, or project schedule, to name just a few examples. 

A Report Writer report is much more than a simple printout of the headings and data in your 
tables. As you create a report, you determine how the data will be arranged, analyzed, and 
formatted. 

As you design a report, you can move text and data freely around the screen. You can create 
calculations to analyze your data. You can apply fonts and styles to selected areas of the 
report. You can add lines, boxes, and graphic images to improve the presentation quality of 
your reports. You can also preview the report on screen at any time, print it, and/or save the 
report output in a disk file. When you’ve completed the report, you can save the enti
report definition so that you can run or modify the report at any time.

Chapter 4, “Sample Reports,” contains examples of some of the many types of repor
can create with Report Writer. These reports include various types of columnar listing
mailing labels.

How Does Report Writer Produce a Report?
Report Writer produces a report by selecting and presenting information from selecte
tables according to a report definition that you create. This report definition usually 
includes:

• The name of the master table that serves as the initial source of data for the report.

• A report layout that indicates where objects will be placed on the report. You can
Report Writer Wizards, a template, an Instant Report, or an existing report as the
starting point for your new report. 

• Print information to specify how to print the report, display it, or save it as a file.

Optionally, the report definition can also include additional information that controls h
data is selected, analyzed, and presented. 

The report definition can also include:

• Database relation information that indicates which other related tables will provide 
information for the report and how the information in these tables is related to the
master table or to other tables.

• Sort and group information to specify the order in which to sort the data and 
categories in which to summarize it.

• Field definitions for calculations and totals derived from data in your tables.
1-2 Getting Started with Report Writer, Xbase Edition
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• Selection conditions (referred to as a query) to specify which records you want to 
include in the report. 

• Formatting information that specifies which fonts and/or styles will be used in the
report.

• Imported bitmapped images for presentation quality.

• Lines and boxes added as graphic enhancements.

No matter how you structure your report, the data in your tables remains the same. R
Writer simply permits you to view the data from a variety of perspectives. 

Composite Records

When you run a report, Report Writer reads the specified tables and creates a composite 
record structure containing all the fields from the tables used in the report, as well as 
total and calculated fields created in Report Writer. The information in these compos
records is then presented in the layout specified in the report definition, with any sor
grouping, and querying you specified. The report is displayed and/or printed using the
and styles you selected, along with any images you imported and any lines and boxe
drew on the report layout.

Templates

A template is simply a report definition with a specialized purpose: to serve as the com
starting point for a series of reports. You can create and modify templates the same way you
do reports. By saving templates in libraries, you keep your templates separate from 
reports. As a result, you can easily save, retrieve, manage, and distribute templates.

Instant Reports

If you create a report by selecting Instant Report on the File⇒ New dialog box, Report 
Writer generates an Instant Report layout for you automatically. The Instant Report layo
includes the following items:

• All fields in the master table (or as many as will fit horizontally on the layout).

• Calculated fields for master table name, date, time, page number, and number o
records printed.

• Grand totals of all numeric fields that have decimal places.

In many cases, you can use the Instant Report layout as a starting point for creating
own layouts. 
Getting Started with Report Writer,  Xbase Edition 1-3
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Report Wizards

Report Wizards provide the capability of creating three common types of instant reports 
(Labels, Basic Columnar, or Grouped Columnar) without having to navigate through 
Report Writer’s menus and dialog boxes. The Wizard dialog boxes lead you through
several simple steps in the preparation of each report type, giving you the opportunit
preview the report output.

To use the Report Wizards, select File ⇒ New and select “Report Wizards” on the New 
dialog box. To see sample output for each of the report types, right-click on the appro
illustration. 

Saving a Report

Saving reports in Report Writer is easy.

1. After creating a report, select File ⇒ Save.  You can save the report either as a 
compound document file (the preferred format for Windows 95/NT) or into an 
existing report library. (Note that you should only save into a report library only to 
maintain compatibility with an earlier version of Report Writer as this feature is no 
longer supported.) 

2. Enter a name for the report.  If you save the report as a compound document file, 
the name can have up to 250 characters and the default file extension is .RRW.
1-4 Getting Started with Report Writer, Xbase Edition



tible 
Chapter 2  
Installing Report Writer

This chapter explains how to install and set up Version 8 of Report Writer for Xbase, 
Windows Edition. This information is presented in the following sections:

q System Requirements

q Supported Software

q Stand-Alone Installation and Setup

q Network Installation and Setup

q Managing User Licenses

q Running Report Writer

q Quick Configuration

System Requirements
To run Report Writer, you must have Microsoft Windows® 95/NTTM.  To install Report 
Writer, you must have the following:

• A computer capable of running Microsoft Windows95/NT (3.51 or later)

• 8 MB of memory

• A CD-ROM disk drive

• Approximately 20 MB of disk space

Supported Software
You can develop Report Writer reports using tables created by or completely compa
with the following products: 

• dBASE III, dBASE III+, dBASE IV, or Visual dBASE 

• FoxBase+, FoxPro, or Visual FoxPro

• Clipper

• Visual objects

• Alpha Four or Alpha Five
Getting Started with Report Writer, Xbase Edition 2-1
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Version 8 also supports the following:

• SuccessWare memo (.SMT) and index (.NSX) files

• Flex-File II memo (.DBV) files

• Clipper 5.2 index (.NTX) files

Note that Report Writer does not support binary object data types.

Stand-Alone Installation and Setup
When you run the Report Writer installation program, you select the portions of the Re
Writer package that you want to install. You can also specify the drive and directory w
the Report Writer files will be installed. 

Running the Installation Program 
You can install Report Writer in any directory on any drive.  If the directory you specif
the installation procedure does not exist, Report Writer will create it.

Each Setup dialog box after the first one contains a “Back” button. Select this button
you need to return to the previous dialog box to change a selection or setting. 

Installing Report Writer is a simple process.  You just insert the CD in the CD-ROM d
and follow these steps:

1. Start Windows and insert the Report Writer CD in the CD-ROM drive.

2. Select Run from the Windows Start menu. In the Command Line edit box, type 
<drive>:\setup, substituting the correct drive letter for <drive>, and click OK:

After a pause for initialization, the first of several Startup dialog boxes displays. 
2-2 Getting Started with Report Writer, Xbase Edition



  

Figure 2-1 — Initial Splash Screen and the Welcome Dialog Box

3. In the Welcome dialog box, click on Next to proceed with the installation and display 
the License Agreement dialog box.

Figure 2-2 — License Agreement Dialog Box

  Initial Startup Splash Screen

Welcome to R&R
Getting Started with Report Writer,  Xbase Edition 2-3



4. In the License Agreement dialog box, click on Yes.  You cannot proceed until you 
accept the License Agreement.  After agreeing to the License Agreement, the User 
Information dialog box displays.

Figure 2-3 — User Information Dialog Box

5. Enter your name, the name of your company, and the serial number that is affixed to 
the back of the Report Writer CD case.  Click on Next to display the Setup Type dialog 
box.  If at any time you need to return to a prior dialog box, click on the Back button to 
return to the dialog box.  Similarly, if you need to abort the installation process, click 
on the Cancel button.  Report Writer will return your system back to its prior state 
without installing any files.

.

2-4 Getting Started with Report Writer, Xbase Edition
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Figure 2-4 — Setup Type Dialog Box

6. Click on the type of setup you want to install:
– Typical
– Compact
– Custom  

If you select Custom the following dialog box displays. 

Figure 2-5 — Setup Components Dialog Box

7. Click on Next. After clicking on Next, the Setup Status Indicator dialog box displa

Figure 2-6 — Setup Status Indicator Dialog Box
Getting Started with Report Writer,  Xbase Edition 2-5
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8. When the installation program finishes installing the components, the Setup is 
complete information box displays.  At this time you are asked to complete and mail 
in your registration form.  Click OK.

The installation is now complete.  Setup created a folder that includes the following 
program item icons:  

• Report Designer program

• Report Viewer 

• Scheduler and Scheduler Status, which allows preset scheduling of reports, que
and other applications

• User Management, which enables you to manage Report Writer serial numbers 
multi-user access on a network (you must have a valid serial number for each 
concurrent user).

• Report Converter, which allows you to convert report definitions to and from vario
Report Writer for Windows and Report Writer for DOS formats  

• The Runtime Sample (if you chose to install the Runtime and Sample files), whic
illustrates the basic operation of Runtime; 

• Report Writer Dictionary Builder, which enables creation and maintenance of rep
dictionary files to provided descriptive information in Report Writer about databas
fields; 

• Developing Applications, an on-line version of the Developing Applications manual.
2-6 Getting Started with Report Writer, Xbase Edition
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Network Installation and Setup
Report Writer supports network installations with concurrent-use licensing.  Multiuser’s 
packs are available separately.  R&R Runtime is licensed for royalty-free distribution and 
unlimited use.  

The installation procedure for installing on a network is similar to the installation for a
Stand-alone installation.    You can place the Report Writer directory on either a local 
or a network drive, providing you have write privileges on the network drive.  Note that
need to make sure that you have the appropriate number of concurrent-use licenses to run
Report Writer. 

Managing User Licenses 
When you install Report Writer, the installation program creates a file in the Report W
program or link directory that includes the serial number(s) of the copy of Report Writer 
you installed. You must have a licensed serial number for each concurrent Report W
user (Report Writer automatically keeps track of the number of concurrent users). 

You can add serial numbers using either Setup or Report Writer’s User Managemen
program (which is available as an icon in the Report Writer program group). You can
use the User Management program to check the status of all installed serial number
unlock any serial number that has become unavailable as the result of a system failu
user reboot while Report Writer is running, and to remove serial numbers.

Running the User Management Program

To maintain the serial number file — that is, to unlock, add, delete, or view the statu
serial numbers — run the User Management program (RRWUSERS.EXE). This pro
is installed in the Report Writer directory and is available as an icon in the Report W
program group. 

Adding Serial Numbers

To add one or more serial numbers for multiuser access, do the following:   

1. Run the User Management program in either of these ways:

– From the Windows Start menu, highlight R&R Report Writer and select User 
Management.

– Select Run from the Windows Start menu, enter the path and name of the Us
Management program (c:\Program Files\RR Report Writer\RRWUsers.exe), 
then press Enter.
Getting Started with Report Writer,  Xbase Edition 2-7
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The Report Writer User Management dialog box appears (see Figure 2-7). 

Figure 2-7 — User Management Dialog Box

2. Select Add  to display the Add - Enter Serial Number dialog box. 

Figure 2-8 — Add - Enter Serial Number Dialog Box

3. Enter the serial number and click OK.  Repeat this process, as necessary.

The User Management dialog lists the added serial number(s), which will now be 
available to Report Writer. 

Unlocking Serial Numbers

When any network user is running Report Writer, a serial number is assigned to that user. 
While the serial number is in use, it is unavailable until the user to whom it is assigned exits 
Report Writer.

If the network fails or a user boots or turns off a workstation while Report Writer is running, 
that user’s assigned serial number will appear to be in use even though no one is using it. 
In this case, a workstation ID or “In Use” appears to the right of the serial number in 
User Management dialog box. To make the serial number available for use again, ru
User Management Program. Highlight the locked serial number and select Unlock. T
serial number will then be available for use (indicated by “Inactive”).
2-8 Getting Started with Report Writer, Xbase Edition
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Deleting Serial Numbers

The process for removing one or more serial numbers for multiuser access from 
RRWUSERS.DAT is similar to the procedure described in “Adding Serial Numbers.”

1.  Run the User Management program to display the User Management dialog bo
shown in Figure 2-7 and click OK.  The Delete - Enter Serial Number dialog box 
displays.

2. Enter the serial number you want to delete, and click OK.  Repeat this process, a
necessary.   

When you delete serial numbers, they are removed from the list in the User 
Management dialog and become unavailable to any user on the network.  The U
Management dialog box re-displays with and undated list of valid serial numbers
available to Report Writer.  

Running Report Writer
Use either of these methods to start Report Writer:

– Highlight R&R Report Writer from the Windows Start Programs and select 
Report Writer.  Once you create reports, if you double-click on the report 
(filename.rrw) using Windows Explorer, Report Writer opens automatically. 

– Select File ⇒ Run and enter the path and name of the Report Writer program
(RRW.EXE); then press Enter. 

As you create and modify reports, you can access on-line help by selecting Help or by
pressing F1. 

To familiarize yourself with Report Writer’s commands and features, follow the 
instructions in Chapter 3, “Creating Your First Report,” for creating and saving a sim
report.

Quick Configuration
After installing Report Writer, you can begin creating reports immediately, without 
changing the initial configuration. However, you may want to change some of Repor
Writer’s default settings. For example, when you first run the program, Report Writer loo
for and creates report library files in the Report Writer program directory. Using the De
File Settings dialog, you can change the default library directory so that you can retr
your report library files more quickly. 
Getting Started with Report Writer,  Xbase Edition 2-9



Setting Default Directories and Extensions

To set default directories and extensions for your data files, report libraries, and image files, 
follow these steps:  

Setting Default Directories

The default directories specify where data files, report libraries, and image files are located 
and where new report libraries will be created.
2-10 Getting Started with Report Writer, Xbase Edition
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Chapter 3  
Creating Your First Report

In this chapter, you will create a report using a Report Writer sample table. You will then 
take a “quick tour” of the essential Report Writer skills and commands as you modify
simple report. 

As you develop this report, you will gain experience in:

• Working with Report Writer menus and the report layout

• Selecting sort fields

• Typing, moving, and formatting fields

• Drawing boxes on the layout

• Displaying, saving, and retrieving reports

The tutorial procedure in this chapter uses the Report Writer sample tables in the rrsample 
subdirectory. For these files to be available, you must have selected the “Sample Fil
option when you installed Report Writer.

This chapter is divided into the following sections:

q Creating an Instant Report

q Modifying the Report

q Saving the Completed Report

Creating an Instant Report
To begin creating the report, start Report Writer. Then do the following:  

1. Select File⇒ New and select “Instant Report” on the New dialog box. The Maste
Table dialog box displays. 

2. In the Directories list box, double-click on “Sample” to open the Folder containing
sample files. (Note that if you selected “Program directory will be read-only” durin
installation, the Sample folder is in the link directory you specified.)

3. In the File Name list box, double-click on “rrprices.dbf” to select it as the master t
for this report. 
Getting Started with Report Writer, Xbase Edition 3-1



4. Report Writer displays a report layout that places all the fields from the selected table 
on the layout, with column titles inserted for each field.

In many cases, you can use the Instant Report layout as a starting point for creating your 
own layouts.

As Figure 3-1 illustrates, the instant report layout also includes Report Writer calculated 
fields for master table name, date, time, number of records printed, and page number, as 
well as totals of all numeric fields that have decimal places. 

Figure 3-1 —Report Writer Instant Report
3-2 Getting Started with Report Writer, Xbase Edition
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Figure 3-2 — Band Types explained on an Instant Report 

Each line is identified by type in the Band Area at the left as Figure 3-2 shows. The 
following is an explanation of the band types for this report:  

• Title band lines print or display once per report at the beginning of the first page o
a separate title page. 

• The Page Header band line appears at the top of each page. 

• The Record band contains information from each composite record. For this report, 
the Record band includes the product code, description, and price fields; when a 
is generated, data from these fields is printed or displayed for each record. Note
the Record band displays as a single line on the layout, but the printed report will 
many record lines — one for each record in the database. 

• Summary band lines appear once per report at the end of the last page or on a s
summary page.  

• Page Footer band lines appear at the bottom of each page. 

Title

Header

Summary

Footer

Record
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Previewing the Report

To see how the line types and their positions on the layout control how they will appear 
when printed, you can preview the report. 

1. Select File ⇒ Print Preview (or the Preview button on the Standard Toolbar) to 
display the report. 

2. To see a close-up display of the report page, click the Zoom In button (the third button 
from the left). 

Figure 3-3 — Zoomed Preview Display

3. To exit from Preview and return to the report layout, select the Close button (the solid 
black square) or press Esc. 
3-4 Getting Started with Report Writer, Xbase Edition
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Modifying the Report
Although you can use the Instant Report “as is,” you can modify this basic report defin
in many ways to suit the purposes of individual reports. In the following sections, you
make several changes to the report layout and change the order in which Report Write
the data that it retrieves for the report.

Replacing the Report Title 

The first change you will make is replacing the default fields in the Title lines with a m
descriptive title. Like many title fields, the one you will add is simply text typed on the
report layout. Follow the steps outlined below to learn how to delete fields from the re
layout and add a text field.

Deleting the Default Fields

Before adding a new Title field, you delete the default fields on the first two Title lines. T
of these fields (Date_rr and Time_rr, which display the current date and time) are calculate
fields. When you delete calculated fields from the layout, they are not removed from
composite record structure; you can re-insert them at any time. The other two fields ar
fields; you can use Edit ⇒ Undo to replace a text field if you accidentally delete one.

1. To select all four fields on the Title lines, use the mouse to outline them: click in 
upper left corner of the display area, drag the mouse down and to the right, then
release the mouse button when the four fields have been outlined. Each field is 
enclosed in a box to indicate that it is selected.

2. Select Edit⇒ Clear (or the Trashcan button). The fields disappear from the layou

Inserting a New Title

Follow these steps to insert a new title on the report:

1. Click on the second Title line (leave one blank line at the top), type Product Price 
List, and press Enter. If you make a mistake, press Backspace to erase the inco
character; then continue. 

2. To position the title field, first select it; then click and drag it to the right until the 
position indicator on the Ruler Line is at 1 inch.  
Getting Started with Report Writer,  Xbase Edition 3-5
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Formatting the Title
After you have typed or inserted a field on the layout, you can modify its size and format, 
erase it, or assign print styles and fonts to it. To apply formatting, you can use the Format 
menu choices, the Formatting Toolbar buttons, or the Field Properties dialog box. You will 
now format the Product Price List field using each of these methods.

Changing the Font 

To apply a different font to the field:

1. Select the Product Price List text field that you typed on the first title line. Note that 
the field text appears on the Status Bar at the bottom of the window. 

2. Select Format ⇒ Font and select any font that appears in the font list; in our example, 
we use Arial, one of the TrueType fonts available with Windows. Note that you can 
also select a font by opening the Font list box on the Formatting Toolbar or by opening 
the Field Properties dialog box (right-click on the field and select Properties) and 
selecting Font.

Changing the Point Size

To change the field’s point size, follow these steps:

1. If the Product Price List field isn’t still selected, click to select it.

2. Select a point size from the Size menu on the Formatting Toolbar (alternatively, 
can use Format ⇒ Font or the Field Properties dialog box). You can use any point s
that is available for the font you applied to the field. In our example, we use 24-p
Arial. 

Making the Field Bold

The last step is to assign a print style to the title use Field Properties:

1. Select the field and press F4 (or right-click on the field and select Properties).

2. Select Font; then select Bold in the Style box. Select OK. 

3. Select Close.

The field now appears in boldface. (As a quicker alternative to using the Field Prope
dialog box, you can simply select the field and click the Bold button on the Formattin
Toolbar). 
3-6 Getting Started with Report Writer, Xbase Edition



Creating a Box Around the Title

You can call attention to particular areas of a report by using the mouse to draw lines and 
boxes on the report. After inserting a box, you can control the thickness and color of the 
border, turn off one or more of the sides of the box, and add a shading pattern to the box 
background.

Drawing a Box

Follow these steps to draw a box around the Product Price List field:

1. Click the Box button on the Standard Toolbar. The cursor changes to a crosshair and a 
box outline.

2. Position the crosshair at the upper left corner of the field. Click and drag the mouse so 
that the box outline surrounds the field. Release the mouse to position the lower right 
corner.  

Formatting the Box

By default, a new box has a black border on all sides and the thinnest available border. 
Using the Box Properties dialog box, you can increase the border thickness. To do so, 
follow these steps:

1. Right-click on one of the box borders and select Properties; the Box Properties dialog 
box opens.

2. Open the Thickness menu and select a medium-weight border from the five choices. 
Select OK. Your report layout should look like the one shown in Figure 3-4.
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Figure 3-4 — Report Layout with Formatting

Sorting Data 

Initially, Report Writer presents data in the order in which it is stored in the master table. 
You can use the Sort Order dialog box to select a different sort order that will override the 
master table order. The sort field(s) you select will determine the order in which the 
composite records will print or display. Sorting records in Report Writer does not change 
the order of the records in your table(s).

Changing Sort Order

In the following steps, you will select a field to control the order in which the records will 
display or print. 

1. Select Database ⇒ Sort Order (or the Sort Records button on the Standard Toolbar) to 
display the Sort Order dialog box.  

2. Open the list box for the first sort field slot. This menu displays all data fields from the 
report tables, as well as certain Report Writer calculated and total fields. 
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3. Select PRICE as the first sort field. The “X” in the Ascending check box means th
records will be sorted by price, in lowest to highest order. Select OK. 

4. Select File ⇒ Print Preview (or the View button) to display the report. Note that th
first record displayed is the one with the lowest price (49.95), and the other record
displayed by ascending price. 

5. Click the Close button, then select Database⇒ Sort Order again. Turn off the 
Ascending check box for the first sort level to change the order to Descending (s
Figure 3-5). Select OK. 

Figure 3-5 — Sort Order Dialog Box

6. Select File ⇒ Print Preview again to display the report. Note that the first record 
displayed is now the one with the highest price (249.00), and the other records are 
displayed by descending price. Click the Close button to return to the report layout. 
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Saving the Completed Report
To save the report, select either File ⇒ Save. You can save the report either as a compound 
document file (the preferred format for Windows 95) or into an existing report Report 
Writer).

1. To save the report definition as a template, in the “Save as type” drop-down men
select Template Library.

2. Enter a name for the report. If you save the report as a compound document file
name can have up to 300 characters and the default file extension is .RRW. 

3. Choose a report type in the Save as type edit box.  The options are Report File (*
Report Library (*.RP5), and Template Library (*.RT5).

If you save the report into a report library, the report name can have up to 30 
characters. Note that you cannot have duplicate report names in a given library.

4.  Select OK. 

The report is saved in the current report library, and Report Writer returns to the r
layout. 

To exit to Windows, select File⇒ Exit. 
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Chapter 4  
Sample Reports

This section contains sample reports in commonly used formats. Each report is 
accompanied by a brief explanation of the Report Writer features illustrated in the report. 
These explanations summarize the procedures for creating each report; they do not provide 
step-by-step instructions. After reading the explanation for a sample report, you can refer 
to the relevant chapters in Using Report Writer for more detailed information about 
commands, dialogs, and procedures.

The following reports are included in this section:

q Basic Columnar Report

q Grouped Columnar Report

q Summary Columnar Report

q Mailing Labels Report

If you chose the Typical option when you installed Report Writer, these reports are 
available in the Sample Folder of the Report Writer program directory or link directory you 
specified. The reports use only the sample tables provided with Report Writer. 

These reports use Times New Roman and Arial, two TrueType fonts available with 
Windows 95 and Windows/NT. These reports should preview and print correctly on any 
system on which these fonts are installed. All reports are saved with an HP LaserJet IV 
printer as their destination. To change the print destination, select File ⇒ Print Setup and 
select any available printer.

Note that the examples of printed output provided for the sample reports simulate the 
printed appearance of each report. There may be minor differences in spacing and 
formatting between these simulations and the actual report output. 
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Basic Columnar Report

Page Header
Use Insert ⇒ Create Band Line to create five page header lines. Type the text fields on 
the layout. Select the title text field and use Format ⇒ Font to apply 18-point Arial 
bold to it; select the line and then select Format ⇒ Band Line Justify to center it. Click 
and drag to select the column headings; then use Format ⇒ Font to apply 12-point 
Arial bold to them. Click and drag fields to position them. To apply shading behind the 
column headers, use Insert ⇒ Box to draw a box around them. Then select 
Format ⇒ Field and click each of the “Show” boxes to remove the X. In the Shad
group box, select the solid pattern, make the foreground black, and select a light
background color. 

Record Band
A one-line Record band prints for each composite record, as many times as will 
between the page header and the bottom margin. Use File⇒ Page Setup to set the 
margins. Use Calculations⇒ Calculated Field to create a calculated field for the ord
total; its expression is PRICE*QUANTITY. Insert fields in the Record band using 
Insert⇒ Field. Use Database⇒ Sort Order to sort on the product description field. 
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Summary
A two-line Summary band prints at the end of the report. Create the Summary lines 
with Insert ⇒ Create Band Line. Select Insert ⇒ Line to draw the line above the 
summary fields. Type the text fields on the next line. Use Calculations ⇒ Total Field 
to create a count of the product description field and sums of the quantity and order 
total fields, all reset as grand totals. Insert these fields in the Summary band. Use 
Format ⇒ Field to apply a currency format to the order total sum.
 

Sales By Product
Product Description Unit Price Qty Order Total

PC Com 49.95 5 249.75

PC Com 49.95 5 249.75

PC Com 49.95 5 249.75

PC Com 49.95 10 499.50

PC Com 49.95 20 999.00

PC Com 49.95 20 999.00

PC Com 49.95 20 999.00

PC Com 49.95 20 999.00

PC Com 49.95 25 1,248.75

PC Com 49.95 45 2,247.75

PC Database 149.00 10 1,490.00

PC Database 149.00 10 1,490.00

PC Database 149.00 10 1,490.00

PC Database 149.00 10 1,490.00

PC Database 149.00 15 2,235.00

PC Database 149.00 20 2,980.00

PC Database 149.00 25 3,725.00

PC Database 149.00 25 3,725.00

PC Database 149.00 30 4,470.00

PC Database 149.00 45 6,705.00

PC Database 149.00 45 6,705.00

PC Database 149.00 50 7,450.00

PC Database 149.00 50 7,450.00

PC Graphics 249.00 5 1,245.00

PC Graphics 249.00 5 1,245.00

PC Graphics 249.00 5 1,245.00

PC Graphics 249.00 20 4,980.00

PC Project Planner 149.00 5 745.00

PC Project Planner 149.00 5 745.00

PC Project Planner 149.00 10 1,490.00

PC Project Planner 149.00 10 1,490.00

PC Project Planner 149.00 15 2,235.00

Grand Totals: 32 Orders 600 $75,566.25
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Type the text and insert the date field for the report title; use Format ⇒ Field to 
specify the mm/dd/yyyy date format. Use Format ⇒ Trim to print the date field at the 
end of the text field. Select the title lines and use Format ⇒ Band Line Justify to 
center them. Use Insert ⇒ Line to draw lines above and below the title. Use Format ⇒ 
Field to set the line thickness. Type the text for the column headings; then click and 
drag an outline around them (or Ctrl-click on each) and select Format ⇒ Font to apply 
18-point Times Roman bold. 

Record Band
Insert additional record lines with Insert ⇒ Band Line. Multi-line columnar reports 
are useful when all of the information will not fit across the page on one line. This 
format also allows more flexibility for special formats such as a name and address 
layout. The single blank record line on the layout will leave a blank line before each 
record and make the report output more readable. To apply the Times Roman 12-point 
font to the fields on the record lines, click and drag an outline to select them and then 
select Format ⇒ Font.

Page Footer
Create a calculated field to print the page number using Calculations ⇒ Calculated 
Field and the PAGENO() function. Use Format ⇒ Trim “Print at End of Previous 
Field” to print the page number immediately following the text field. Select the lin
and use Format ⇒ Band Line Justify to center it.
4-4 Getting Started with Report Writer, Xbase Edition



ld. 

roup 

 with 
t the 

te 
age 
Getting Started with Report Writer,  Xbase Edition 4-5

Grouped Columnar Report

Page Header
Type the text for the title and column headings. Assign 18-point Arial bold to the title field 
using Format ⇒ Font; select the line and select Format ⇒ Band Line Justify to center it. 
Again using Format ⇒ Font, assign 14-point Arial bold to the column headings. Draw a 
line beneath the column headings using Insert ⇒ Line, then use Format ⇒ Field to set the 
line’s width. 

Record Band
Use Database⇒ Sort Order to select product description as the first sort and group fie
Select Database ⇒ Group Order to open the Group Order window; click in the “Print 
Once” box for the product description group field, so the description prints once per g
per page.

Group Footer
A four-line group footer prints after every group of records with the same product 
description. Create three group footer lines for the product description group with 
Insert⇒ Create Band Line. Then create sums of the quantity and total amount fields
Calculations⇒ Total Field. Reset the sums on the product description field; then inser
sums in the description Footer band.

Page Footer
Use Calculations⇒ Calculated Field and the DATE() and PAGENO() functions to crea
calculated fields for the system date and the page number. Insert these fields on a P
Footer line. Use Format⇒ Field to give the date the mmm–yy format.



Summary Columnar Report

Title
Use Format ⇒ Font to apply bold, 12-point Times New Roman to the title lines. Set 
the left and right margins using File ⇒ Page Setup. Center the lines using Format ⇒ 
Band Line Justify. Draw a box around the title fields using Insert ⇒ Box. Set the 
thickness of the box borders using Format ⇒ Field.

Page Header
Type the column heading text fields and apply bold, 12-point Times New Roman to 
the page header line.

Group Header
Records are grouped by company name and then by product description. Use Database 
⇒ Sort Order to select the company and description fields as sort and group fields. 
Use Insert ⇒ Create Band Line to create the group header and group footer lines. 
Apply 10-point Times New Roman to the lines.
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Second Group Footer
To produce a summary report, delete the Record band. The second group footer band 
will contain subtotals for each group of records with the same product description. Use 
Calculations ⇒ Total Field to create the item quantity field. Select Sum as the total 
type, QUANTITY as the field to total, and the product description field as the reset 
level. Use Calculations ⇒ Calculated Field to create an order total field that multiplies 
the item quantity by PRICE.

First Group Footer
A three-line group footer prints after every group of records for the same company. 
Create subtotals of the item quantity and order total fields with Calculations ⇒ Total 
Field (Sum). Select COMPANY as the reset level. Type text to label these subtotals 
and insert the fields on the second company group footer line. Leave the last group 
footer line blank so there is space between each group.

Summary
A five-line Summary band prints once at the end of the report. Create grand totals of 
the company subtotals with the Calculations ⇒ Total Field Sum, Average, Minimum, 
and Maximum options. Type the labels and insert the fields; then right-align the labels 
and fields
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Mailing Labels Report

Label and Page Dimensions
The label and page dimensions are determined by the Avery label you select. To choose a 
label, select Format ⇒ Record Layout; open the Label Type drop-down menu and choose 
a label type. Width and height for the selected label are shown in the Dimensions box. For 
this report, Avery Product #5163 (Address/Shipping) was selected; label dimensions are 
4.19 by 2 inches.

Company Name
Type the company name directly onto the report layout. Insert the line beneath using Insert 
⇒ Line, then set the line’s thickness using Format ⇒ Field. To insert the logo on the line,
select Insert ⇒ Picture, draw the image area, then select the image file to insert. As 
necessary, size and reposition the image using the mouse.

Mailing Address
Insert the name and address fields with Insert ⇒ Field; type commas and spaces as 
necessary. Use Format ⇒ Trim to eliminate blank space between the first and last nam
and between the city, state or country, and code. The Format ⇒ Record Layout “Compress
Record/Group Lines” setting eliminates blank lines within the address. 

Test Pattern
Before printing the labels, use File ⇒ Print and select Test Pattern from the “Print” list bo
to check their alignment. 

The illustration on the next page shows a portion of the report as it might appear wh
printed on labels.
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David Adams
PC Products
489 Main Street
Phoenix, AZ 85014

Eastern Computer Supply, Inc.

421 Park Avenue, Worcester, MA  01615

Roger Britten
Micro Supply
12 Exchange Street
Birmingham, AL  35244

Eastern Computer Supply, Inc.

421 Park Avenue, Worcester, MA  01615

Gisela Beck
Trachten-Beck GmbH
Münchenerstr. 88
Ottobrunn, Germany

Eastern Computer Supply, Inc.

421 Park Avenue, Worcester, MA  01615

Carter Clayburn
Software House
345 Lincoln Avenue
Hanover, NH  03755

Eastern Computer Supply, Inc.

421 Park Avenue, Worcester, MA  01615

George Empain
Ets. Lumière et Frères
12, rue de l'Etoile
Paris, France

Eastern Computer Supply, Inc.

421 Park Avenue, Worcester, MA  01615

Ernest Bartholdi
Bartholdi et Fils
45, rue de la Cité
Avignon, France

Eastern Computer Supply, Inc.

421 Park Avenue, Worcester, MA  01615

Steven Carson
Carson Associates
400 Summer Street
Silver Spring, MD 20904

Eastern Computer Supply, Inc.

421 Park Avenue, Worcester, MA  01615

Frank Cleary
Business Productivity Center
490 Webster Avenue
Austin, TX  78757

Eastern Computer Supply, Inc.

421 Park Avenue, Worcester, MA  01615

Gregory Anderson
Discount Software
1900 South Street
Indianapolis, IN  46260

Eastern Computer Supply, Inc.

421 Park Avenue, Worcester, MA  01615

Patrick Binet
Union des Programmeurs
88, rue de Tourcoing
Nice, France

Eastern Computer Supply, Inc.

421 Park Avenue, Worcester, MA  01615
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