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README.RTF Release Notes 
Jan 2006 Version 12.0.001 Update 

Welcome to the Latest Member of the Liveware Family 
In late 1999, Liveware Publishing acquired from Wall Data the exclusive license to 
develop and market R&R Report Writer.  After a successful release of Version 8.1 
in mid 2000, and Version 9 in 2001, in October 2002 we delivered R&R Version 10 
followed by a 10+ release in May 2003. In January of 2006 we released a new 
version and a new product name ReportWorks. In our Spring 2005 ReportWorks 
release we added an exciting new easy to implement, powerful feature, dynamic 
parameteRRs. 

The current ReportWorks Infinity 2006 update adds several new features and a 
new upgrade strategy that eliminates the need to purchase future upgrades. 

 

Objectives 
Version 12 continues with our commitment to release product updates on an on-
going basis that will incorporate features that will make our user community even 
more productive. 

In Version 12 we have we have added a variety of new features that are designed 
to reduce the reporting writing learning curve by seamlessly storing report and 
data information behind the scenes as reports are created so that you use and 
even report on that information. 

This document provides an overview of what is new or changed in Version 12 and 
also lists any late breaking information that was not included in the on line Help 
files. We have also made a number of corrections in this update that are listed 
starting on page 20. 
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New Features Summary 

 

Security Enhancements 
• Password Protection  

• Auto Recovery  

 

Report Layout Enhancements 
• Enhanced Ruler Display  

• Multiple Field Alignment  

• No Records Found Band Line  

• Expanded Undo/Redo  

 

Field Enhancements 
• Enhanced Field Lists  

• Longer Computed Field Names  

• Find and Replace in Expressions  

• Total field Enhancements  

 

ParameteRR Enhancements 
• Updated ParameteRR Dialog  

• Static List ParameteRRs  

• Dynamic List ParameteRRs  

 

Table Enhancements  
• Updated Relation Dialog 

• Table Dictionary Support 

 

Other Enhancements 
• Updated Export 

• Duplicate Field Export Warning  

• Updated Charting Support  
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Password Protection 

You can now optionally set a Designer and/or a Runtime password for a report 
using the menu selection File->Security.  

 

This password may be up to 30 characters in length. Passwords are case-sensitive 
and may include spaces and special characters. When you enter a password, your 
input is masked on the display.  

When a password(s) has been set in File Security, when the report is save (via 
Save or Save As) you will be asked to Verify the password(s) by re-entering it. 
The report will not be saved unless the password(s) correctly matches the 
password(s) that was set in File Security. 

When you open a report in the report designer or at runtime that has a password, 
you will be given a screen to enter to the password. This password must match 
the password that is saved in the report or you will not be able to open or run the 
report. 

 

CAUTION: 

Once a report is saved with a password, it can only be opened if that password is 
correctly entered. 

There is no facility available to recover a lost password. 

If you set a password for a report, it is strongly suggested that you print your 
Report Specifications before saving the report and keep this information in a 
secure place. Any Designer or Runtime password will be printing in the header 
area of the report specification. You will then have a record of the password(s) 
that has been set for the report. 

Note that password information is NOT saved to the Report Librarian. 

 

Reports with a saved password cannot be converted to any other format using the 
ReportWorks Report Converter. 
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Auto Recovery 

A new Auto Save item has been added to Options->Preferences.   

You can now check a box to enable R&R to automatically save changes to a 
backup copy of the report are working on every 1-120 minutes. When auto 
recovery is enabled, R&R saves a copy of the current report in the same directory 
as the original at the designated interval.  It also writes the name of the save file 
in the RRW.INI file. Should there be a problem causing R&R closes unexpectedly, 
the next time that you open the Report Designer, you will be asked if you want to 
open the auto saved file. This file will contain all of the changes to the file that was 
open in your last designer session up to the last recovery point. 
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Enhanced Ruler Display 

We have added the ability to display the horizontal and vertical positioning rulers 
at the top and the right of the layout screen. Selecting View->Rulers now brings 
you to a tabbed ruler dialog where you can use a checkbox to optionally display of 
each of the four available rulers. 
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Multiple Field Alignment 

You can select multiple fields on the report layout and then use the menu 
command Format->Align to align all of the selected objects to have the same 
selected placement as last selected object. 

 

For example you could select 3 fields on 3 separate band lines and then choose 
Format->Align Left to move the first two selected objects to have the same left 
edge as the last selected object. 
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No Records Found Band Line 

In previous versions of R&R, there was not a way in the report designer to produce 
output when no records were found for the report.  We have added a new No 
records found checkbox that it available for Title band lines.   

 

When this box is checked, the title band will print both in the designer and at 
runtime only when no records are found.  This allows you place appropriate text 
on a no records found line that will allow you to produce a report even when no 
records are found. 

In runtime, the older behavior of always printing the title and summary when no 
records are found, required the creation of conditional calculations to return 
specific output for a no records found condition. The new method is a much 
simpler approach. 

To allow reports created in earlier versions to use the older behavior, a new 
setting is available in the [Defaults] section of RRW.INI. 

If the INI contains the line: 

NoRecHDR=0 

Runtime will print all title and summary bands when no records are found (the old 
default) rather than only those title bands with a No records found checkbox. 

The new behavior will be used if NoRecHDR is set to 1 or is absent from the INI. 

The new version continues to honor the  /H switch on the runtime command line. 
If a /H is used, there will be no report output at runtime when no records are found. 
Any title band having a no records enabled, will not print. 
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Enhanced Undo and Redo 

The range of report layout actions that can be reversed using Edit->Undo has 
been expanded from moving or removing an object or band line to include: 

o Inserting any object on the layout 

o Inserting any band line 

o Any Font/Size/Attribute changes 

o Resizing of objects on layout 

 

We have also added an Edit->Redo to the menu as well as adding Undo and Redo 
buttons to the Standard toolbar.  Clicking on these buttons will display a list of the 
most recent actions that can be changed.  When you undo an action, you also 
undo all actions above it in the list.  

If you later decide you did not want to Undo an action you can use the Redo 
button to reverse it. 
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Enhanced Field Lists 

Field list dialogs have been changed to a more descriptive columnar format.  

 

What is displayed 

The Name column includes both the field name and any optional comment or 
dictionary description. 

The table column shows the field’s table alias. 

The type column shows the field’s data type. 

The class column shows the field’s usage class. 

An asterisk * before a field name indicates that the field is currently used on the 
report layout. 

Right clicking on a field displays any available dictionary information. 

 

Customizing the list 

Clicking on a column heading sorts the list by that column and adds a sort 
direction indicator. 

Clicking on a sorted column heading again reverses the sort order.  

Clicking on a column header separator bar allows you to resize a column. 

 

Filtering the list 

The Go to Field box allows you to enter one or more characters to limit the field 
list to display only field names beginning with the characters you have entered. 
Press backspace to clear the box and display all fields. 
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Longer Computed Field Names 

The maximum length for computed field names in R&R has been extended from 10 
to 30 characters. 

 

 

Find and Replace in Expressions 

A new Replace button is now available with calculated expression dialogs.  

 

This new dialog allows you to quickly edit calculated expressions containing 
repeated values.  For example a calculated expression: 

(Q1_2004+ Q2_2004+Q3_2004+Q4_2004)*Disc2004 

 

could use a single replacement string (Replace 2004  with 2005) and become the 
2005 calculation: 

 

(Q1_2005+ Q2_2005+Q3_2005+Q4_2005)*Disc2005 
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Total field enhancements 

Dialog changes 
The total field and auto total dialogs have been changed to use a tabbed format. 
Each tab now provides more instructive information and detailed help on each 
component of total creation. 

 

Multi Edit 

We have also added a new Multi Edit button to the Total Fields dialog.  Multi Edit 
allows you to select several total fields and then make the same edit changes to 
each one.  For example you could select a Group1, Group2 and Grand Total that 
sum the numeric field QTYSOLD and change the sum to be an average.  
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Updated ParameteRR Dialog 

The dialogs for creating parameters within the designer and for entering values at 
runtime have been updated. 

 

Static ParameteRR Lists 

ParameteRR fields now support the definition of of a static list values so that a 
pre-defined value may be selected from a list when a report is run.  

A parameteRR can be defined within the designer to use a static list of defined 
values and a short description can be entered for each one.  List parameteRRs can 
be of character, numeric, date or date time data type.   

 

Dynamic ParameteRR Lists 

Dynamic ParameteRRs allow you to select a lookup DBF table along with a value 
field from that table. When the report is executed, the end user can then display a 
lookup dialog that allows the user to browse the lookup table and select a value. 
The browse dialog displays the key value field in the first column and then to the 
right displays ALL of the fields from the lookup table. And should the lookup table 
be unavailable or should the user want to use a value that is not in the table, a 
non-lookup value can be manually entered. 
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Table enhancements 

Updated Relation Dialog 

The table relation dialog has been changed to use a tabbed format. Each tab now 
provides more instructive information and detailed help on each component of 
linking related tables in a report. 

 

Table dictionary support 

A new Dictionary button is now available when selecting a master or related table. 
When this button is selected, you can view or edit the Data Dictionary definition for 
the selected table. 
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Updated Export 

The Export dialog has been changed to a tabbed format with separate tabs for 
Type, Mail Options and Export Options. 

 

In Mail Options the Subject and Message fields now can be selected from a field 
list rather than manually entered. This is particularly useful for email bursting 
where each email message can now be completely customized for each recipient. 

 

Duplicate Field Export Warning 

If the first 10 characters of two field names on a band line that is being exported 
to a DBF or viewed as a Result Set are the same, a new warning message is 
issued.  In previous versions, the duplicate field was simply omitted without any 
warning. 
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Report File Compatibility with Earlier R&R Releases 

As in all Version 9 and above releases, Version 12 will not allow you to save a 
report into an existing RP5 report library either as a Save or a Save As.  If you 
attempt to do so, you will get an error dialog that will say: "R&R no longer 
supports rewriting a report into a library file." 

Reports saved in Version 12 can be opened with previous R&R versions; however, 
you will get a warning message that will say: 

"Warning: Unrecognized report information encountered. Report might have been 
made with a newer R&R. Clicking OK will open the report, but some report 
features will not be available." 

If you then save the report, any newer features will be removed from that report 
file. 

The exception is for ParameteRR fields. Support for parameteRR fields was added 
in R&R Version 9. 

When a report containing ParameteRR fields is opened in a pre-Version 9 release, 
the ParameteRR field will be treated as a calculated field whose value is the default 
that was set for the ParameteRR. If saved in Version 8.x and then re-opened in 
Version 9 or above, the former ParameteRR field will then remain as a calculated 
field. 
If a report contains a computed field whose name is longer than 10 characters 
(the old limit), earlier versions will recognize the longer name without error since 
the restriction in earlier releases was on the creation of field names rather than 
the usage of field names. 

If a password is set for a report using the new File Security option, that report 
cannot be opened or run in any earlier R&R release.  If you do try to do so, you 
will get an "Invalid Report Revision" error. It also cannot be opened in the Report 
Conversion Utility. 

 

 

Know issues/Other Information 

The following lists issues known to be present in this release along with 
information not contained in the Help/Documentation files. 

 

Serial Numbers 
The Version 12 installer and User Management Programs will only accept serial 
numbers having a Version 12 product key.  You cannot use serial numbers that 
were valid in earlier releases. 

 

Upgrading to Version 12 from earlier releases 
If you are installing Version 12 on a machine has an existing installation of either 
R&R Xbase or SQL it is recommended that you back up any modified R&R files and 
then un-install that copy prior to the installation of Version 12. 

What to back up: 
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• Any user function library (RR.UDF for Xbase, RSW.UDF for SQL) 

• RSWSQL.INI (If modified after original installation. SQL only) 

• RRW.SRT for Xbase, RSW.SRT for SQL (if modified after original 
installation) 

• The initialization files \windows\RRW.INI for Xbase, \windows\RSW.INI for 
SQL 

• Report Librarian data files (all files with extension DBF, CDX and FPT in the 
/RL subdirectory). 

 

You can then restore/upgrade these files after installation of Version 12. 
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Documentation 
A PDF printable documentation set is available on the Version CD in the PDFDOCS 
subdirectory along with a copy of the install program for the Adobe Acrobat 
Reader. 

 

Available Files: 

README12.PDF 

ReportWorks V12 Installation Guide.pdf 

 

Xbase V12 User Guide.pdf 

SQL V12 User Guide.pdf 

 

Xbase V12 Developing Applications.pdf 

SQL V12 Developing Applications.pdf 

 

ReportWorks Report Librarian.PDF 

ReportWorks Data Dictionary Editor.PDF 

ReportWorks Rapid Runner User Guide.pdf 

ReportWorks Conversion and Shortcut Utilities.pdf 

Using the R&R Sample Files.PDF 
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Version 12 Installed Executable files 
 

Installed in program directory 

RRW.EXE Xbase Report Designer 
RRWRUN.EXE Xbase Runtime executable 
RSW.EXE SQL Report Designer 
RSWRUN.EXE SQL Runtime executable 
RRWUSERS.EXE Xbase User Management 
RSWUSERS.EXE SQL User Management 
RRCNVRT.EXE Report Conversion Utility 
RRICON.EXE Runtime Shortcut Maker 
FASTIDX.EXE* Flexlink indexer 
RRBROWSE.EXE* Result set browser 
RRAUTO.EXE* Excel pivot export routines  
RRCHART.EXE* Excel Chart export routines  
RRSQLWIZ.EXE SQL Report Conversion wizard 
RRWIZ.EXE* R&R Report Wizard  

Installed in the RL subdirectory 

RL.EXE Report Librarian 

RLCAT.EXE* Report Librarian Xbase cataloger  

RLSCAT.EXE* Report Librarian SQL cataloger  

DCALCUP.EXE* Uploads calculations to data dictionary  

DDFLDUP.EXE* Uploads field information to data dictionary 

DDTBLUP.EXE* Uploads table information to data dictionary 

FLDVIEW.EXE* Called by designer to view field dictionary information  

REGISTRY.PRG* Called by data dictionary load program 

TBLLINKS.EXE* Called by designer Join Help button 

TBLVIEW.EXE Called by designer to view table dictionary information. 

Installed in the RapidRun subdirectory 

RAPIDRUN.EXE Rapid Runner executable 
RRCONSOL.EXE* Called by Rapid Runner to consolidate to existing DBF 
* Indicates a program called internally by another executable 
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SQL/ODBC Connectivity Issues 

SQL Server7/2000 
If you are opening reports that were created against earlier versions of SQL 
Server, you may incorrectly receive the error “Data source not found and no 
default specified”.  Or you may see the error “Invalid connection or query handle” 
when creating or modifying reports. To resolve these problem, edit your 
c:\windows\RSW.INI file and add the line: 

UseQEConnect=1 

to the [Database] section.  You will need to add a [Database] section if it is not 
already present in the file.  Then save the file and restart R&R. 

If you are connecting to SQL Server with an alternative driver, the following 
problems will be present: 

Auto SQL reports are limited to selecting tables from the current login database. 

If you need to join tables across databases, you can create a User SQL report or 
can within you database build a View table that references tables from a different 
database. 

Data from Unicode field types (nchar, nvarchar, ntext) will appear as empty when 
the report is executed.  Support for these field types will be added in subsequent 
update. 

 
 

Oracle 
If you are running from an Oracle8 client machine using the SQORA32.DLL ODBC 
driver, data from VARCHAR2 fields may be incorrectly returned.  

If you are experiencing slow report retrieval or excessive delays when defining 
calculated or total fields, there is an optional INI file setting that should correct 
this problem. Edit your C:\windows\RSW.INI file and add the line: 

ALWAYSRR=1 

to the [Database] section. If your RSW.INI does not currently have a [Database] 
section, you can add one at the end of the file. Then save the file and re-start 
R&R. 
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MS Access 
The unmatched records join option for Access is limited to reports containing a 
single join. If you need to use this option and include more than two tables in your 
report, the workaround is to create a query within Access that joins your tables as 
required and then use this Access query as the master file for your report. 

 
 

Visual FoxPro 
The Microsoft Visual FoxPro driver gives error “No table names were found for this 
datasource” when try to create a new report using free tables. 
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12.1.001 Corrections 
Each product release incorporates both new functionality and software corrections. 
The following changes/corrections have been made since the last Version 11.1.009 
update that was released in August 2005. If you are migrating from any previous 
release, you can also check the individual release notes for each version. These 
notes are posted on our web site page 
http://www.livewarepub.com/download.htm 

 
CORRECTED SINCE THE 11.1.009 UPDATE 

 
• Logical band line properties are correctly retained when a report is saved 

and re-opened. 

• If you create a new calculation in the relation or line properties dialog, the 
new calculation now appears immediately in the field selection list. 

• When you open the designer and cancel the popup dialog, icons for File and 
Open are now available. 

• ParameterRR scope values containing spaces are correctly honored. 

• ParameteRR value entry screen places focus in new value field in overwrite 
mode. 

• When a parameteRR is copied, the new parameteRR inherits the display 
format of the original field. 

• Sort fields can now be deleted when report contains 8 defined sort fields. 

• Total Multi-edit correctly retains any saved conditions or comments. 

• Totals retain their correct accumulation frequency when edited in the SQL 
version. 
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ISSUES NOT YET CORRECTED BY THIS UPDATE 
 

• The * before a field name currently indicates that a field is used on the 
report layout rather than used within the report. 

• Reports saved with a custom page size under Windows XP or 2000 will only 
honor that page size if opened on the machine where the report was 
created. 

• Printer tray selections for some printers may not be correctly saved in a 
report file. 

• When exporting to HTML with an embedded object, the embedded object is 
not converted to file that is referenced as the object in the HTML. 

• Cancel button from modal dialogs called by Calc Expression dialog also 
cancels any manual edit changes that were made to the expression prior to 
calling the dialog. 

• When an error is found in a calculated expression, the edit cursor should be 
placed at the source of the error as it was in earlier releases rather than 
highlighting the entire expression. 

• Report containing large data set and several group level graphs causes a 
memory leak and eventual crash. 

•  Picture from field may cause image distortion if the size of the image file 
varies from the placeholder blank.bmp file. 

• Email bursting does not work correctly if burst level is anything other than 
the first group level. 

 

We are currently working to address the above problems. 
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Other News 
The name “Liveware” is meant to reflect the need to augment your hardware and 
software with the help of live people to help you leverage your hardware and 
software investment.  Liveware Publishing is proud to offer you the following 
services: 

 

• Technical Support 

• Training Classes 

• Training Manuals 

• Report Design Consultation 

• Report Template Construction 

• Data Dictionary Building and Maintenance 

• Custom Development of Runtime Prompts 

• Custom Development of Report Wizards 

 

For information about these services, please contact our knowledgeable staff at  

800-936-6202 or mailto:liveinfo@livewarepub.com. 

 

Please visit our web site at http://www.livewarepub.com/ for the latest 
information about R&R Report Writer.  

 
Also, check out our R&R User Discussion Forum  

http://207.5.19.19/cgi-bin/dcforum/dcboard.pl 

Where you can exchange ideas with other R&R users. 

 

We Want to Hear from You! 

Please send your ideas, suggestions and comments to 
mailto:liveinfo@livewarepub.com.  

 

 

 


